antiCisco blogs » Blog Archive » Настройка multi-area OSPF на маршрутизаторах Huawei.

antiCisco blogs


блоги по технологиям и оборудованию cisco от инструкторов

Опубликовано 24 Январь , 2012

C выходом китайского вендара Huawei на рынок энтерпрайз становиться актуальной задача по интеграции их устройств с существующей сетевой инфраструктурой, построенной на решениях Cisco.
В статье будет показана настройка протокола OSPF на маршрутизаторах Huawei с ОС VRP3/VRP5 и их добавление к домену маршрутизации OSPF, реализованном на роутерах Cisco.

Топология сети примерно следующая:
RTA и RTC – роутеры Cisco. Минимальный конфиг у них такой:

RTA RTB
interface FastEthernet0/0
ip address 10.1.1.2 255.255.255.252
duplex auto
speed auto

interface FastEthernet0/1
no ip address
duplex auto
speed auto

interface FastEthernet0/1.10
encapsulation dot1Q 10
ip address 192.168.0.1 255.255.255.0

interface FastEthernet0/1.20
 encapsulation dot1Q 20
 ip address 192.168.1.1 255.255.255.0

interface FastEthernet0/1.30
 encapsulation dot1Q 30
 ip address 192.168.2.1 255.255.255.0

interface FastEthernet0/1.40
 encapsulation dot1Q 40
 ip address 192.168.3.1 255.255.255.0

router ospf 1
 log-adjacency-changes
 passive-interface default
 no passive-interface FastEthernet0/0
 network 10.1.1.2 0.0.0.0 area 0
 network 192.168.0.0 0.0.3.255 area 0
interface FastEthernet0/0
no ip address
duplex auto
speed auto

interface FastEthernet0/0.100
encapsulation dot1Q 100
ip address 192.168.10.1 255.255.255.0

interface FastEthernet0/0.200
encapsulation dot1Q 200
ip address 192.168.11.1 255.255.255.0

interface FastEthernet0/1
ip address 172.1.1.2 255.255.255.252
duplex auto
speed auto

router ospf 1
 log-adjacency-changes
 passive-interface default
 no passive-interface FastEthernet0/1
 network 172.1.1.2 0.0.0.0 area 1
 network 192.168.10.0 0.0.0.255 area 1
 network 192.168.11.0 0.0.0.255 area 1

RTB – роутер Huawei, вот его то и будем настраивать. Для начала на роутере Huawei нужно настроить сетевые интерфейсы и присвоить им IP адреса. Делаем это так:

<RTB>system-view
[RTB]interface Ethernet 0/0/0
[RTB-Ethernet0/0/0]ip address 10.1.1.1 30
[RTB-Ethernet0/0/0]q
[RTB]interface Ethernet 0/0/1
[RTB-Ethernet0/0/1]ip address 172.1.1.1 30
[RTB-Ethernet0/0/1]q
[RTB]interface Ethernet 0/1/0
[RTB-Ethernet0/1/0]ip address 192.168.20.1 24
[RTB-Ethernet0/1/0]q
[RTB]interface Ethernet 0/1/1
[RTB-Ethernet0/1/1]ip address 192.168.21.1 24

Активировать интерфейсы не надо, в отличие от роутеров Cisco они по умолчанию в активном состоянии.
Чтобы каждый роутер имел уникальный идентификатор в LSDB, нужно его задать:

[RTB]router id 127.1.1.2

Вообще-то, эта команда опциональная. Если ее не ввести, то маршрутизатор сам определит идентификатор на основе большего IP адреса своего loopback интерфейса, ну а если и лупбек не настроен, то будет использован больший IP адрес физического интерфейса.
Теперь переходим к поднятию ospf на роутере Huawei:

[RTB]ospf

На самом деле, нужно указать еще и id процесса ospf на роутере, если этого не сделать, то по умолчанию process-id будет 1.
Чтобы настроить area и включить сетевые сегменты в нее, нужно сделать следующее:

[RTB-ospf-1]area 0 <<определяем арию и переходим в режим ее настройки
[RTB-ospf-1-area-0.0.0.0]network 10.1.1.1 0.0.0.0 <<помещаем сеть в арию 0
[RTB-ospf-1-area-0.0.0.0]network 192.168.20.0 0.0.0.255
[RTB-ospf-1-area-0.0.0.0]area 1
[RTB-ospf-1-area-0.0.0.1]network 172.1.1.1 0.0.0.0
[RTB-ospf-1-area-0.0.0.1]network 192.168.21.0 0.0.0.255

Описание сетевого сегмента состоит из двух частей, это идентификатор сети и шаблонная маска (wildcard mask).
Небольшой тюнинг поможет запретить отправку и прием OSPF сообщений через интерфейсы, где нет OSPF маршрутизаторов:

[RTB-ospf-1]silent-interface Ethernet0/1/0
[RTB-ospf-1]silent-interface Ethernet0/1/1

Вот вроде все. Теперь можно проверить отношения смежности между роутером Huawei и устройствами Cisco. Для этого делаем следующее:

[RTB] display ospf peer
                OSPF Process 1 with Router ID 127.1.1.2
                               Neighbors
  Area 0.0.0.0 interface 10.1.1.1(Ethernet0/0/0)'s neighbor(s)
  RouterID: 192.168.3.1     Address: 10.1.1.2        <Opaque-capable>
        State: Full  Mode: Nbr is Master  Priority: 1
        DR: 10.1.1.2  BDR: 10.1.1.1
        Dead timer expires in 33s
        Neighbor has been up for 00:06:39
  
Area 0.0.0.1 interface 172.1.1.1(Ethernet0/0/1)'s neighbor(s)
  RouterID: 192.168.11.1    Address: 172.1.1.2       <Opaque-capable>
        State: Full  Mode: Nbr is Master  Priority: 1
        DR: 172.1.1.1  BDR: 172.1.1.2
        Dead timer expires in 37s
        Neighbor has been up for 00:02:06

Ну что, видим, что отношение смежности установлено. А что же в таблице маршрутизации? Ее вывод можно посмотреть вот так:

[RTB]display ip routing-table
Routing Table: public net
Destination/Mask   Protocol Pre  Cost        Nexthop         Interface
---вывод пропущен---
192.168.0.1/32     OSPF     10   2           10.1.1.2        Ethernet0/0/0
192.168.1.1/32     OSPF     10   2           10.1.1.2        Ethernet0/0/0
192.168.2.1/32     OSPF     10   2           10.1.1.2        Ethernet0/0/0
192.168.3.1/32     OSPF     10   2           10.1.1.2        Ethernet0/0/0
192.168.10.1/32    OSPF     10   2           172.1.1.2       Ethernet0/0/1
192.168.11.1/32    OSPF     10   2           172.1.1.2       Ethernet0/0/1

И в заключение. Проверим коннективити с использованием команды ping от IP адреса 192.168.21.1 на маршрутизаторе Huawei на адрес 192.168.0.1 маршрутизатора Cisco:

[RTB]ping -a 192.168.21.1 192.168.0.1
  PING 192.168.0.1: 56  data bytes, press CTRL_C to break
    Reply from 192.168.0.1: bytes=56 Sequence=1 ttl=255 time=2 ms
    Reply from 192.168.0.1: bytes=56 Sequence=2 ttl=255 time=1 ms
    Reply from 192.168.0.1: bytes=56 Sequence=3 ttl=255 time=2 ms
    Reply from 192.168.0.1: bytes=56 Sequence=4 ttl=255 time=2 ms
    Reply from 192.168.0.1: bytes=56 Sequence=5 ttl=255 time=2 ms

  --- 192.168.0.1 ping statistics ---
    5 packet(s) transmitted
    5 packet(s) received
    0.00% packet loss
    round-trip min/avg/max = 1/1/2 ms









 

Метки: ,
Опубликовано: Holywar

 

» Оставить комментарий

Вы должны войти чтобы прокомментировать.