Сообщения без ответов | Активные темы Текущее время: 16 сен 2019, 03:04



Ответить на тему  [ Сообщений: 13 ] 
PPTP клиент, NAT и CEF - как это заставить работать вместе? 
Автор Сообщение

Зарегистрирован: 03 мар 2019, 11:25
Сообщения: 33
Я бы успокоился, но в интернетах есть легенда, что ЭТО возможно!
https://www.opennet.ru/openforum/vsluhf ... /1576.html

Как и полагается в настоящей легенде, летописец забыл написать главное или страница с чудесным рецептом утрачена.

Вдруг найдется новый Мерлин, Гендальф или еще какой волшебник от цыцки?

Короче. Cisco 881, PPTP туннель к провайдеру, NAT на Dialer0.

Если "no ip CEF" - фсе работает.

Стоит включить "ip CEF" - пакеты ответов на outside-интерфейсе дропаются.

Код:
cisco.k259#sh run
Building configuration...

Current configuration : 7415 bytes
!
! No configuration change since last restart
!
version 15.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service internal
!
hostname cisco.k259
!
boot-start-marker
boot system flash:c880data-universalk9-mz.154-3.M9.bin
boot system flash:c880data-universalk9-mz.154-3.M8.bin
boot-end-marker
!
!
logging discriminator FAN-FAIL severity drops 3 facility drops FAN mnemonics drops FAN_FAILED
logging buffered discriminator FAN-FAIL
no logging console
logging monitor discriminator FAN-FAIL
enable secret 5 $1$WSti$mDMsh6sXY2iguEI/Mchiy1
enable password xxxxxxxx_
!
no aaa new-model
memory-size iomem 10
clock timezone GMT 5 0
!
crypto pki trustpoint TP-self-signed-3690135629
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-3690135629
 revocation-check none
 rsakeypair TP-self-signed-3690135629
!
!
crypto pki certificate chain TP-self-signed-3690135629
 certificate self-signed 01
  3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
        quit
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip dhcp excluded-address 192.168.0.1 192.168.0.7
!
ip dhcp pool k259
 import all
 network 192.168.0.0 255.255.255.0
 default-router 192.168.0.1
 domain-name k259
 dns-server 192.168.0.12 8.8.8.8
 lease 0 2
!
!
!
ip domain name k259
ip name-server 192.168.0.12
ip name-server 8.8.8.8
ip inspect WAAS flush-timeout 10
no ip cef
no ipv6 cef
!
!
vpdn enable
!
vpdn-group PPTP_CLIENT
 description Rostelecom ISP
 request-dialin
  protocol pptp
  pool-member 1
 initiate-to ip 10.0.0.1
!
cts logging verbose
license udi pid CISCO881W-GN-E-K9 sn FCZ164190LZ
!
!
username atest privilege 15 secret 4 6in4Lru2ZZ8N8cUij4q7JvPlkL..hsURCkjm.d4NOR2
!
!
!
!
no cdp run
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0
 no ip address
!
interface FastEthernet1
 no ip address
!
interface FastEthernet2
 no ip address
!
interface FastEthernet3
 no ip address
!
interface FastEthernet4
 ip address 10.0.47.132 255.255.255.0
 ip flow ingress
 duplex auto
 speed auto
!
interface wlan-ap0
 description Service module interface to manage the embedded AP
 ip address 10.10.11.1 255.255.255.0
 arp timeout 0
!
interface Wlan-GigabitEthernet0
 description Internal switch interface connecting to the embedded AP
 no ip address
!
interface Vlan1
 description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$
 ip address 192.168.0.5 255.255.255.0 secondary
 ip address 192.168.0.1 255.255.255.0
 ip flow ingress
 ip nat inside
 ip virtual-reassembly in
 ip tcp adjust-mss 1452
!
interface Dialer0
 description $ETH-WAN$
 mtu 1450
 ip address negotiated
 ip flow ingress
 ip nat outside
 ip virtual-reassembly in
 encapsulation ppp
 ip tcp adjust-mss 1410
 dialer pool 1
 dialer idle-timeout 0
 dialer string 123
 dialer persistent
 dialer vpdn
 ppp authentication ms-chap-v2 callin
 ppp chap hostname 90.157.26.245
 ppp chap password 0 xxxxxxxxxxx
 no cdp enable
!
ip forward-protocol nd
ip http server
ip http access-class 23
no ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip http path flash:
!
no ip ftp passive
ip dns server
ip nat translation max-entries all-host 1000
ip nat inside source static tcp 192.168.0.12 3389 interface Dialer0 3389
ip nat inside source list 101 interface Dialer0 overload
ip route profile
ip route 0.0.0.0 0.0.0.0 Dialer0 3
ip route 10.0.0.1 255.255.255.255 10.0.47.1
ip route 10.10.11.0 255.255.255.0 wlan-ap0
!
dialer-list 1 protocol ip permit
!
snmp-server community k259 RO
access-list 1 remark internet
access-list 1 remark CCP_ACL Category=2
access-list 1 permit 192.168.0.0 0.0.0.255
access-list 23 remark CCP_ACL Category=17
access-list 23 permit 10.10.10.0 0.0.0.7
access-list 23 permit 192.168.0.0 0.0.0.15
access-list 101 remark internet2
access-list 101 remark CCP_ACL Category=2
access-list 101 remark test 2
access-list 101 permit ip 192.168.0.0 0.0.0.255 any
access-list 150 remark WAN rule
access-list 150 remark CCP_ACL Category=1
access-list 150 remark WAN rule entry
access-list 150 permit ip any any
!
 vstack
banner exec ^C
% Password expiration warning.
^C
banner login ^C
-----------------------------------------------------------------------
Cisco Configuration Professional (Cisco CP) is installed on this device.
^C
!
line con 0
 login local
 no modem enable
line aux 0
line 2
 no activation-character
 no exec
 transport preferred none
 transport input all
line vty 0 4
 access-class 23 in
 privilege level 15
 password xxxxxxxx
 login local
 transport input telnet ssh
!
ntp master
ntp update-calendar
ntp server ntp2.stratum2.ru
!
end


17 мар 2019, 12:41
Профиль

Зарегистрирован: 10 окт 2012, 09:51
Сообщения: 2673
по вашей ссылке
Цитата:
Всем огромное спасибо. Смена прошивки на 15.3(2)T решила мою проблему.


17 мар 2019, 13:37
Профиль

Зарегистрирован: 03 мар 2019, 11:25
Сообщения: 33
Это я видел.
Но у меня 15.4(3)M9

Вроде - новее?


17 мар 2019, 13:54
Профиль

Зарегистрирован: 10 окт 2012, 09:51
Сообщения: 2673
новее, не значит лучше. Вполне возможно, что pptp нормально работало только на T версии.


17 мар 2019, 17:45
Профиль

Зарегистрирован: 03 мар 2019, 11:25
Сообщения: 33
Перебирать версии - слишком затратно по времени.
Кроме того, летописец указывал не некие "изменения в конфигурации".

Подождем более осведомленных волшебников.


17 мар 2019, 17:54
Профиль

Зарегистрирован: 12 июл 2012, 17:44
Сообщения: 675
Э-э-э, не хочу вызвать "бурю оваций", но я бы попробовал уже за это время тот ИОС, который упоминался. А то вдруг и изменения в конфиге не нужны.


21 мар 2019, 00:12
Профиль

Зарегистрирован: 03 мар 2019, 11:25
Сообщения: 33
1. Есть другая работа.
2. Сама цыцка тоже работает.

Поэтому желателен более надежный совет.


21 мар 2019, 05:40
Профиль

Зарегистрирован: 10 окт 2012, 09:51
Сообщения: 2673
смените провайдера, куда еще надеждней


21 мар 2019, 10:35
Профиль

Зарегистрирован: 03 мар 2019, 11:25
Сообщения: 33
Это так, возможно.
Но есть более простой путь - выкинуть цыцку.

Вопрос сейчас не о смене провайдера, а о работе цыцки.


21 мар 2019, 10:49
Профиль

Зарегистрирован: 01 янв 1970, 03:00
Сообщения: 816
купите smartnet - он стоит копейки для вашего роутера.
Там точно нужные вам волшебники в чалмах


21 мар 2019, 11:03
Профиль

Зарегистрирован: 29 май 2017, 21:19
Сообщения: 746
PPTP клиент - не поддерживается цицкой т.к. это очень устаревший протокол он может работать, а может не работать, что вы ещё хотите, кроме перебора ИОСов Вам ничего не светит, за это время можно было перебрать все ИОСы которые существуют для этой платформы.....


21 мар 2019, 11:21
Профиль

Зарегистрирован: 03 мар 2019, 11:25
Сообщения: 33
>>купите smartnet
Это что за ругательное слово?

>>PPTP клиент - не поддерживается цицкой т.к. это очень устаревший протокол он может работать, а может не работать,
Да, я уже слышал твои советы про MTU. Можно не продолжать.


21 мар 2019, 11:59
Профиль

Зарегистрирован: 03 мар 2019, 11:25
Сообщения: 33
google знает это слово...

Боюсь, что цыцка досталась мне многа дешевле... эээ рыночной цены. За два рубля, если точно.
Врядли, корыстные хоттабычи из цыцки почешутся за сравнимые деньги.


21 мар 2019, 12:07
Профиль
Показать сообщения за:  Поле сортировки  
Ответить на тему   [ Сообщений: 13 ] 

Кто сейчас на конференции

Сейчас этот форум просматривают: Google [Bot] и гости: 15


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  
Создано на основе phpBB® Forum Software © phpBB Group
Designed by ST Software for PTF.
Русская поддержка phpBB