Anticisco
http://www.anticisco.ru/forum/

NAT между интерфейсами
http://www.anticisco.ru/forum/viewtopic.php?f=2&t=11129
Страница 1 из 1

Автор:  djakson [ 04 окт 2019, 05:21 ]
Заголовок сообщения:  NAT между интерфейсами

Возникла тут задача но что то в растерянности как реализовать.
Нужно сделать двухсторонний NAT между организациями.
Имеется в наличии cisco isr 4321 и связь между организациями оптика.
Куда в данной задаче вешать то ip nat inside ip nat outside ?


п.с. Маршрутизацию не предлагать есть нюансы.

Вложения:
nat.jpg
nat.jpg [ 10.96 КБ | Просмотров: 812 ]

Автор:  crash [ 04 окт 2019, 07:09 ]
Заголовок сообщения:  Re: NAT между интерфейсами

а зачем двухстороний? Может хватит натить одну сеть?

Автор:  Silent_D [ 04 окт 2019, 07:35 ]
Заголовок сообщения:  Re: NAT между интерфейсами

djakson писал(а):
Маршрутизацию не предлагать есть нюансы.

А может вы опишете исходную задачу? С нюансами.

Автор:  Black Fox [ 04 окт 2019, 10:31 ]
Заголовок сообщения:  Re: NAT между интерфейсами

И роутинг всё равно будет, даже если и с NAT. :-)

Автор:  djakson [ 04 окт 2019, 11:17 ]
Заголовок сообщения:  Re: NAT между интерфейсами

Вроде нашел ответ.

Router(config-if)# ip nat enable
Router(config)# access-list 101 permit ip 10.0.2.0 0.0.0.255 10.0.1.0 0.0.0.255
Router(config)# access-list 102 permit ip 10.0.3.0 0.0.0.255 10.0.2.0 0.0.0.255
Router(config)# ip nat source list 101 interface fa 0/0 overload
Router(config)# ip nat source list 102 interface fa 0/1 overload

Сегодня попробую в CPT.

Автор:  Praporwik [ 04 окт 2019, 12:19 ]
Заголовок сообщения:  Re: NAT между интерфейсами

какая задача стоит, что решено было остановиться на double nat?

конфиг должен быть рабочим, но еще nat прописывается на конкретном интерфейсе

http://www.routereflector.com/2017/02/t ... co-router/

interface Ethernet0/0
ip address 1.1.1.2 255.255.255.252
ip nat outside
interface Ethernet0/1
ip address 10.255.255.1 255.255.255.0
ip nat inside

Автор:  djakson [ 04 окт 2019, 12:56 ]
Заголовок сообщения:  Re: NAT между интерфейсами

В этих филиалах есть свои удаленные подключения предоставляемые провайдером оптикой и статическими ip на концах
и которые соединены коммутаторами L3 и поднята маршрутизация средствами SVI. На оконечном оборудовании прописаны маршруты.
Сейчас всё работает на linux iptables но решили заменить на железку. Пробовал на mikrotik - но он под нагрузкой дохнет.
Из разных филиалов ходят как в локальные сети так и в сети за коммутаторами.

Автор:  Silent_D [ 04 окт 2019, 16:52 ]
Заголовок сообщения:  Re: NAT между интерфейсами

Пока единственный нюанс, который видно, это неумение настроить маршрутизацию.
И поэтому решили нафигачить NAT-а.

Автор:  Praporwik [ 04 окт 2019, 18:36 ]
Заголовок сообщения:  Re: NAT между интерфейсами

djakson писал(а):
В этих филиалах есть свои удаленные подключения предоставляемые провайдером оптикой и статическими ip на концах
и которые соединены коммутаторами L3 и поднята маршрутизация средствами SVI. На оконечном оборудовании прописаны маршруты.
Сейчас всё работает на linux iptables но решили заменить на железку. Пробовал на mikrotik - но он под нагрузкой дохнет.
Из разных филиалов ходят как в локальные сети так и в сети за коммутаторами.


Так тут не в нате дело тогда. Нат это не роутинг же. Тут проблема именно в железке посередине. Нарисуйте подробнее схему и что-куда роутится.

Автор:  Silent_D [ 04 окт 2019, 18:43 ]
Заголовок сообщения:  Re: NAT между интерфейсами

Praporwik писал(а):
Тут проблема именно в железке посередине.
Нарисуйте подробнее схему и что-куда роутится.

Проблема не в железке, а "в головах".
Скорее всего она тут совсем не нужна.
Оптический L2 линк можно пробросить напрямую между удаленными роутерами.
Ну и настроить между ними маршрутизацию соответственно.

Страница 1 из 1 Часовой пояс: UTC + 3 часа
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/