Сообщения без ответов | Активные темы Текущее время: 14 июл 2020, 18:12



Ответить на тему  [ Сообщений: 11 ] 
Cisco AnyConnect нет пинга 
Автор Сообщение

Зарегистрирован: 15 апр 2020, 23:13
Сообщения: 7
Ребята, всем привет !

Помогите, пожалуйста ! Не могу понять в чем проблема, после подключения нет доступа к внутренним ресурсам, опыта в ASA мало, вроде настроил все листы, но пинг до подсети не идет.


ASA Version 9.1(7)32
!
hostname ciscoasa
enable password XXXXX encrypted
names
ip local pool RA-POOL 192.168.100.10-192.168.100.240 mask 255.255.255.0
!
interface Ethernet0/0
nameif outside
security-level 0
ip address 1.1.1.1 255.255.255.252
!
interface Ethernet0/1
no nameif
no security-level
no ip address
!
interface Ethernet0/1.100 < Интерфейс интерконнекта с ISR, где и лежит сеть 192.168.8.0/24
vlan 100
nameif inside
security-level 100
ip address 172.100.0.2 255.255.255.252
!
interface Ethernet0/2
shutdown
no nameif
no security-level
no ip address
!
interface Ethernet0/3
shutdown
no nameif
no security-level
no ip address
!
interface Management0/0
management-only
nameif management
security-level 100
ip address 10.0.30.40 255.255.255.0
!
ftp mode passive
object network OBJ_NAT_LAN
subnet 192.168.100.0 255.255.255.0
object-group network HOST_DNS
network-object host 8.8.8.8
object-group service SERVICE_DNS
service-object tcp destination eq domain
service-object udp destination eq domain
object-group network NET_LAN
network-object 192.168.100.0 255.255.255.0
object-group network USERS_FULL_ACCESS
group-object NET_LAN
object-group service SERVICE_HTTP_HTTPS
service-object tcp destination eq www
service-object tcp destination eq https
access-list ACL_INSIDE_IN extended permit ip object-group USERS_FULL_ACCESS any
access-list ACL_INSIDE_IN extended permit object-group SERVICE_HTTP_HTTPS object-group NET_LAN any
access-list ACL_INSIDE_IN extended permit object-group SERVICE_DNS object-group NET_LAN object-group HOST_DNS
access-list ACL_INSIDE_IN extended permit icmp object-group NET_LAN any
access-list ACL_ANY standard permit 192.168.100.0 255.255.255.0
access-list ACL_ANY standard permit 192.168.8.0 255.255.255.0
access-list ACL_ANY standard permit 10.0.30.0 255.255.255.0
access-list ACL_ANY standard permit 10.0.100.0 255.255.255.0
access-list ACL_ANY standard permit host 8.8.8.8
access-list ACL_ANY standard permit host 1.1.1.2
pager lines 24
logging asdm informational
mtu outside 1500
mtu inside 1500
mtu management 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
!
object network OBJ_NAT_LAN
nat (inside,outside) dynamic interface
access-group ACL_INSIDE_IN in interface inside
route outside 0.0.0.0 0.0.0.0 1.1.1.2 1
route management 192.168.8.0 255.255.255.0 10.0.30.1 1
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
aaa authentication ssh console LOCAL
http server enable
http 10.0.30.0 255.255.255.0 management
http 192.168.8.0 255.255.255.0 management
no snmp-server location
no snmp-server contact
crypto ipsec ikev2 ipsec-proposal AES256
protocol esp encryption aes-256
protocol esp integrity sha-1 md5
crypto ipsec ikev2 ipsec-proposal AES192
protocol esp encryption aes-192
protocol esp integrity sha-1 md5
crypto ipsec ikev2 ipsec-proposal AES
protocol esp encryption aes
protocol esp integrity sha-1 md5
crypto ipsec ikev2 ipsec-proposal 3DES
protocol esp encryption 3des
protocol esp integrity sha-1 md5
crypto ipsec ikev2 ipsec-proposal DES
protocol esp encryption des
protocol esp integrity sha-1 md5
crypto ipsec security-association pmtu-aging infinite
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set ikev2 ipsec-proposal AES256 AES192 AES 3DES DES
crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map outside_map interface outside
crypto ca trustpoint ASDM_TrustPoint0
enrollment self
subject-name CN=ciscoasa
crl configure
crypto ca trustpool policy
crypto ca certificate chain ASDM_TrustPoint0
certificate 9686975e
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
quit
crypto ikev2 policy 1
encryption aes-256
integrity sha
group 5 2
prf sha
lifetime seconds 86400
crypto ikev2 policy 10
encryption aes-192
integrity sha
group 5 2
prf sha
lifetime seconds 86400
crypto ikev2 policy 20
encryption aes
integrity sha
group 5 2
prf sha
lifetime seconds 86400
crypto ikev2 policy 30
encryption 3des
integrity sha
group 5 2
prf sha
lifetime seconds 86400
crypto ikev2 policy 40
encryption des
integrity sha
group 5 2
prf sha
lifetime seconds 86400
crypto ikev2 enable outside client-services port 443
crypto ikev2 remote-access trustpoint ASDM_TrustPoint0
telnet timeout 5
ssh stricthostkeycheck
ssh 10.0.30.0 255.255.255.0 management
ssh 192.168.8.0 255.255.255.0 management
ssh timeout 5
ssh version 2
ssh key-exchange group dh-group1-sha1
console timeout 0
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
ssl trust-point ASDM_TrustPoint0 outside
ssl trust-point ASDM_TrustPoint0 inside
webvpn
enable outside
anyconnect-essentials
anyconnect image disk0:/anyconnect-win-4.8.03036-webdeploy-k9.pkg 1
anyconnect profiles AnyConnect_VPN_client_profile disk0:/AnyConnect_VPN_client_profile.xml
anyconnect enable
tunnel-group-list enable
cache
disable
error-recovery disable
group-policy GroupPolicy_AnyConnect_VPN internal
group-policy GroupPolicy_AnyConnect_VPN attributes
wins-server none
dns-server value 8.8.8.8
vpn-tunnel-protocol ikev2 ssl-client
split-tunnel-policy tunnelspecified
split-tunnel-network-list value ACL_ANY
default-domain none
webvpn
anyconnect profiles value AnyConnect_VPN_client_profile type user
username test password XXXXXXXX encrypted privilege 15
tunnel-group AnyConnect_VPN type remote-access
tunnel-group AnyConnect_VPN general-attributes
address-pool RA-POOL
default-group-policy GroupPolicy_AnyConnect_VPN
tunnel-group AnyConnect_VPN webvpn-attributes
group-alias AnyConnect_VPN enable
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum client auto
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
inspect ip-options
inspect icmp
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
Cryptochecksum:XXXXXXXXXXXX
: end


20 апр 2020, 13:20
Профиль

Зарегистрирован: 29 май 2017, 21:19
Сообщения: 1098
с вашего конфига вы и не достучитесь до 192.168.8.0 подсети т.к. она у вас маршрутизируется через менеджемент....


20 апр 2020, 13:30
Профиль

Зарегистрирован: 15 апр 2020, 23:13
Сообщения: 7
root99 писал(а):
с вашего конфига вы и не достучитесь до 192.168.8.0 подсети т.к. она у вас маршрутизируется через менеджемент....


Это временное решение,чтобы был доступ к ASA, если даже делаю маршрутизацию через inside, у меня не проходит пинг, даже до шлюза менеджемента.


20 апр 2020, 14:16
Профиль

Зарегистрирован: 15 апр 2020, 23:13
Сообщения: 7
Проблема не с ASA, внутри все нормально бегает, после подключения через anyconnect начинаются проблемы, т.е подсеть который дает pool 192.168.100.0/24 не видит остальные сети.


20 апр 2020, 14:19
Профиль

Зарегистрирован: 29 май 2017, 21:19
Сообщения: 1098
во первых нужно сделать правильный статик роут для подсети 192.168.8.0 на АСА, со стороны рутера тоже указать статик роут для впн пула - чтобы обе железки знали про эти сети.....
во вторых нужно сделать NAT Exempt 192.168.8.0 и другие сети по желанию к впн пулу....
в третьих навесить АКЛ на outside для VPN пула куда ему можно ходить.....
в четвёртых если не понимаете как это делать в ЦМД включите АСДМ.....


20 апр 2020, 15:06
Профиль

Зарегистрирован: 15 апр 2020, 23:13
Сообщения: 7
root99 писал(а):
во первых нужно сделать правильный статик роут для подсети 192.168.8.0 на АСА, со стороны рутера тоже указать статик роут для впн пула - чтобы обе железки знали про эти сети.....
во вторых нужно сделать NAT Exempt 192.168.8.0 и другие сети по желанию к впн пулу....
в третьих навесить АКЛ на outside для VPN пула куда ему можно ходить.....
в четвёртых если не понимаете как это делать в ЦМД включите АСДМ.....



ASA Version 9.1(7)32
!
hostname ciscoasa
enable password XXXX encrypted
names
ip local pool RA-POOL 192.168.100.10-192.168.100.240 mask 255.255.255.0
!
interface Ethernet0/0
nameif outside
security-level 0
ip address 1.1.1.1 255.255.255.252
!
interface Ethernet0/1
no nameif
no security-level
no ip address
!
interface Ethernet0/1.100
vlan 100
nameif inside
security-level 100
ip address 172.100.0.2 255.255.255.252
!
interface Ethernet0/2
shutdown
no nameif
no security-level
no ip address
!
interface Ethernet0/3
shutdown
no nameif
no security-level
no ip address
!
interface Management0/0
management-only
nameif management
security-level 100
ip address 10.0.30.40 255.255.255.0
!
ftp mode passive
object network OBJ_NAT_LAN
subnet 192.168.100.0 255.255.255.0
object network outside_address
host 1.1.1.1
object-group network HOST_DNS
network-object host 8.8.8.8
object-group service SERVICE_DNS
service-object tcp destination eq domain
service-object udp destination eq domain
object-group network NET_LAN
network-object 192.168.100.0 255.255.255.0
object-group network USERS_FULL_ACCESS
group-object NET_LAN
object-group service SERVICE_HTTP_HTTPS
service-object tcp destination eq www
service-object tcp destination eq https
access-list ACL_INSIDE_IN extended permit ip object-group USERS_FULL_ACCESS any
access-list ACL_INSIDE_IN extended permit object-group SERVICE_HTTP_HTTPS object-group NET_LAN any
access-list ACL_INSIDE_IN extended permit object-group SERVICE_DNS object-group NET_LAN object-group HOST_DNS
access-list ACL_INSIDE_IN extended permit icmp object-group NET_LAN any
access-list ACL_ANY standard permit 192.168.100.0 255.255.255.0
access-list ACL_ANY standard permit 192.168.8.0 255.255.255.0
access-list ACL_ANY standard permit 10.0.30.0 255.255.255.0
access-list ACL_ANY standard permit 10.0.100.0 255.255.255.0
access-list ACL_ANY standard permit host 8.8.8.8
access-list ACL_ANY standard permit host 1.1.1.2
pager lines 24
logging asdm informational
mtu outside 1500
mtu inside 1500
mtu management 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
nat (inside,outside) source static OBJ_NAT_LAN OBJ_NAT_LAN destination static outside_address outside_address
!
object network OBJ_NAT_LAN
nat (inside,outside) dynamic interface
access-group ACL_INSIDE_IN in interface inside
route outside 0.0.0.0 0.0.0.0 1.1.1.2 1
route inside 192.168.8.0 255.255.255.0 172.100.0.1 1
route inside 192.168.100.0 255.255.255.0 172.100.0.1 1
route inside 192.168.100.0 255.255.255.0 192.168.8.1 1
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
aaa authentication ssh console LOCAL
http server enable
http 10.0.30.0 255.255.255.0 management
http 192.168.8.0 255.255.255.0 management
no snmp-server location
no snmp-server contact
crypto ipsec ikev2 ipsec-proposal AES256
protocol esp encryption aes-256
protocol esp integrity sha-1 md5
crypto ipsec ikev2 ipsec-proposal AES192
protocol esp encryption aes-192
protocol esp integrity sha-1 md5
crypto ipsec ikev2 ipsec-proposal AES
protocol esp encryption aes
protocol esp integrity sha-1 md5
crypto ipsec ikev2 ipsec-proposal 3DES
protocol esp encryption 3des
protocol esp integrity sha-1 md5
crypto ipsec ikev2 ipsec-proposal DES
protocol esp encryption des
protocol esp integrity sha-1 md5
crypto ipsec security-association pmtu-aging infinite
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set ikev2 ipsec-proposal AES256 AES192 AES 3DES DES
crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map outside_map interface outside
crypto ca trustpoint ASDM_TrustPoint0
enrollment self
subject-name CN=ciscoasa
crl configure
crypto ca trustpool policy
crypto ca certificate chain ASDM_TrustPoint0
certificate 9686975e
XXXXXXXXXXXXX
quit
crypto ikev2 policy 1
encryption aes-256
integrity sha
group 5 2
prf sha
lifetime seconds 86400
crypto ikev2 policy 10
encryption aes-192
integrity sha
group 5 2
prf sha
lifetime seconds 86400
crypto ikev2 policy 20
encryption aes
integrity sha
group 5 2
prf sha
lifetime seconds 86400
crypto ikev2 policy 30
encryption 3des
integrity sha
group 5 2
prf sha
lifetime seconds 86400
crypto ikev2 policy 40
encryption des
integrity sha
group 5 2
prf sha
lifetime seconds 86400
crypto ikev2 enable outside client-services port 443
crypto ikev2 remote-access trustpoint ASDM_TrustPoint0
telnet timeout 5
ssh stricthostkeycheck
ssh 10.0.30.0 255.255.255.0 management
ssh 192.168.8.0 255.255.255.0 management
ssh timeout 5
ssh version 2
ssh key-exchange group dh-group1-sha1
console timeout 0
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
ssl trust-point ASDM_TrustPoint0 outside
ssl trust-point ASDM_TrustPoint0 inside
webvpn
enable outside
anyconnect-essentials
anyconnect image disk0:/anyconnect-win-4.8.03036-webdeploy-k9.pkg 1
anyconnect profiles AnyConnect_VPN_client_profile disk0:/AnyConnect_VPN_client_profile.xml
anyconnect enable
tunnel-group-list enable
cache
disable
error-recovery disable
group-policy GroupPolicy_AnyConnect_VPN internal
group-policy GroupPolicy_AnyConnect_VPN attributes
wins-server none
dns-server value 8.8.8.8
vpn-tunnel-protocol ikev2 ssl-client
split-tunnel-policy tunnelspecified
split-tunnel-network-list value ACL_ANY
default-domain none
webvpn
anyconnect profiles value AnyConnect_VPN_client_profile type user
username test password XXXXXX encrypted privilege 15
tunnel-group AnyConnect_VPN type remote-access
tunnel-group AnyConnect_VPN general-attributes
address-pool RA-POOL
default-group-policy GroupPolicy_AnyConnect_VPN
tunnel-group AnyConnect_VPN webvpn-attributes
group-alias AnyConnect_VPN enable
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum client auto
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
inspect ip-options
inspect icmp
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
Cryptochecksum:XXXXXXXXXXXX
: end


Последний раз редактировалось oneem 20 апр 2020, 16:01, всего редактировалось 1 раз.



20 апр 2020, 15:54
Профиль

Зарегистрирован: 15 апр 2020, 23:13
Сообщения: 7
С маршрутизацией вроде нет проблем. Проблема после подключения по VPN Anyconnect. ASDM я как раз таки не умею работать.

ciscoasa# ping 192.168.8.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.8.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
ciscoasa# ping 10.0.30.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.30.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms


20 апр 2020, 15:57
Профиль

Зарегистрирован: 01 янв 1970, 03:00
Сообщения: 844
oneem писал(а):
route inside 192.168.8.0 255.255.255.0 172.100.0.1 1
route inside 192.168.100.0 255.255.255.0 172.100.0.1 1
route inside 192.168.100.0 255.255.255.0 192.168.8.1 1

Вас ничего не смущает?
oneem писал(а):
С маршрутизацией вроде нет проблем. Проблема после подключения по VPN Anyconnect
Как это нет если есть проблема?

Вам же написал рут, что нужно сделать.

oneem писал(а):
ASDM я как раз таки не умею работать.
Для АСА есть адекватный ГУЙ, а вы пытаетесь доказать комуто, что можете в консоли асу конфигурить.
В свое время еще Кадер сказал - конфигурируйте АСА через ASDM


20 апр 2020, 16:06
Профиль

Зарегистрирован: 15 апр 2020, 23:13
Сообщения: 7
aliotru писал(а):
oneem писал(а):
route inside 192.168.8.0 255.255.255.0 172.100.0.1 1
route inside 192.168.100.0 255.255.255.0 172.100.0.1 1
route inside 192.168.100.0 255.255.255.0 192.168.8.1 1

Цитата:
Вас ничего не смущает?
oneem писал(а):
С маршрутизацией вроде нет проблем. Проблема после подключения по VPN Anyconnect
Цитата:
Как это нет если есть проблема?


Тогда укажите на проблему, не раскидываясь словами.

Цитата:
Вам же написал рут, что нужно сделать.


А зачем вы тогда пишете ?

oneem писал(а):
ASDM я как раз таки не умею работать.
Для АСА есть адекватный ГУЙ, а вы пытаетесь доказать комуто, что можете в консоли асу конфигурить.
В свое время еще Кадер сказал - конфигурируйте АСА через ASDM


Я ничего никому не хочу доказать, не надо умничать, этот форум чтоб делиться опытом или где просиживаются чтоб поумничать, если есть что сказать скиньте лучше гайт, зачем раскидываться словами, чтобы сказать.


21 апр 2020, 10:18
Профиль

Зарегистрирован: 15 апр 2020, 23:13
Сообщения: 7
Вопрос закрыть, буду искать в англоязычных форумах.


21 апр 2020, 10:21
Профиль

Зарегистрирован: 17 окт 2009, 10:27
Сообщения: 31
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface


22 апр 2020, 03:17
Профиль
Показать сообщения за:  Поле сортировки  
Ответить на тему   [ Сообщений: 11 ] 

Кто сейчас на конференции

Сейчас этот форум просматривают: Google [Bot] и гости: 43


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  
Создано на основе phpBB® Forum Software © phpBB Group
Designed by ST Software for PTF.
Русская поддержка phpBB