Сообщения без ответов | Активные темы Текущее время: 04 июл 2020, 08:56



Ответить на тему  [ Сообщений: 6 ] 
Мультикаст через vrf 
Автор Сообщение

Зарегистрирован: 13 май 2009, 09:00
Сообщения: 4
Задавал вопрос на опеннете, но ответа толкового так и не нашел..

Есть два роутера, соединены между собой.

Роутер X:

ip vrf mcast
rd 1234:77
route-target export 1234:77
route-target import 1234:77

ip multicast-routing
ip multicast-routing vrf mcast

interface Vlan777
description test mcast
ip vrf forwarding mcast
ip address 10.10.10.1 255.255.255.0
load-interval 30

address-family vpnv4
neighbor xxx-xxx send-community extended
neighbor x.y.y.z activate
exit-address-family
address-family ipv4 vrf mcast
no synchronization
redistribute connected
exit-address-family

Роутер Y:

ip vrf mcast
rd 1234:77
route-target export 1234:77
route-target import 1234:77

ip multicast-routing
ip multicast-routing vrf mcast

interface GigabitEthernet0/1.777
description test mcast
encapsulation dot1Q 777
ip vrf forwarding mcast
ip address 10.10.20.1 255.255.255.0
no snmp trap link-status
no cdp enable


address-family vpnv4
neighbor xxx-xxx send-community extended
neighbor y.y.y.z activate
exit-address-family
address-family ipv4 vrf mcast
no synchronization
redistribute connected
exit-address-family

Друг друга по IP они видят, маршруты есть, пинги ходят.

Роутер X:sh ip route vrf mcast

10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
C 10.10.10.0/24 is directly connected, Vlan777
L 10.10.10.1/32 is directly connected, Vlan777
B 10.10.20.0/24 [200/0] via x.y.y.z, 3d21h

Как заставить работать мультикаст? Видимо что-то надо прописать на интерфейсах?

PS, роутеры 7609 и 7206

С мультикастом у меня туговато, не люблю я его совсем. Даже не знаю с чего начинать тут...


13 май 2009, 09:03
Профиль
Супермодератор

Зарегистрирован: 01 окт 2008, 12:24
Сообщения: 4436
Ну, исходя из общих соображений, надо запустить протокол мультикастовой маршрутизации, прописав на интерфейсах
ip pim sparse-dence

Для VRFa кажется тоже самое, только с сужением на соотв. VRF.

Ну и включить RP autodiscovery и RP autoannounce (в ключевых словах могу несколько путаться)

ЗЫ RP = randevouz point


13 май 2009, 12:00
Профиль

Зарегистрирован: 13 май 2009, 09:00
Сообщения: 4
Ковырялся неделю, пока пришел вот к чему. AutoRP не стал испоьлзовать, сделал в ручную.
Роутер X

ip vrf mcast
rd 1234:77
route-target export 1234:77
route-target import 1234:77
mdt default 232.0.1.1

interface Vlan777
description test mcast
ip vrf forwarding mcast
ip address 10.10.10.1 255.255.255.0
ip pim sparse-dense-mode
ip igmp version 3
load-interval 30

interface Loopback777
ip vrf forwarding mcast
ip address 10.10.0.2 255.255.255.255
ip pim sparse-dense-mode
ip igmp version 3

ip pim vrf mcast rp-address 10.10.0.1

Роутер Y

ip vrf mcast
rd 1234:77
route-target export 1234:77
route-target import 1234:77
mdt default 232.0.1.1

interface Loopback777
ip vrf forwarding mcast
ip address 10.10.0.1 255.255.255.255
ip pim sparse-dense-mode
ip igmp version 3

interface GigabitEthernet0/1.777
description test mcast
encapsulation dot1Q 777
ip vrf forwarding mcast
ip address 10.10.20.1 255.255.255.0
ip pim sparse-dense-mode
ip igmp version 3

С ПК, включенного с ротутера Y запускаю вещание на 232.0.0.9.
НА ПК, включенном с роутера X включаю VLC смотреть 232.0.0.9. ничего не показывает.
Смотрю дальше:

РОУТЕР X#sh ip mroute vrf mcast 232.0.0.9
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 232.0.0.9), 00:01:28/00:02:19, RP 10.10.0.1, flags: SJC
Incoming interface: Tunnel1, RPF nbr x.y.y.z, Partial-SC
Outgoing interface list:
Vlan777, Forward/Sparse-Dense, 00:01:28/00:02:19, H

Тут как бы все шоколадно, на выход мой влан, на вход - тунель1 (он создался автоматом, видимо так и должно быть).

Смотрю на Роутере Y


Роутер Y#sh ip mroute vrf mcast 232.0.0.9
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 232.0.0.9), 00:05:01/stopped, RP 0.0.0.0, flags: DP
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list: Null

(10.10.20.2, 232.0.0.9), 00:01:48/00:01:20, flags: PT
Incoming interface: GigabitEthernet0/1.777, RPF nbr 0.0.0.0
Outgoing interface list: Null


А вот тут он видит, что приходит с интерфейса, куда включен ПК, но никуда не отправляет дальше. (
Если набрать sh ip mroute vrf mcast count то так и есть, пакеты приходят, но не уходят.
IP Multicast Statistics
3 routes using 1378 bytes of memory
2 groups, 0.50 average sources per group
Forwarding Counts: Pkt Count/Pkts per second/Avg Pkt Size/Kilobits per second
Other counts: Total/RPF failed/Other drops(OIF-null, rate-limit etc)

Group: 232.0.0.9, Source count: 1, Packets forwarded: 0, Packets received: 10083
Source: 10.10.20.2/32, Forwarding: 0/-125/0/0, Other: 10083/0/10083

Group: 239.255.255.250, Source count: 0, Packets forwarded: 0, Packets received: 0


19 май 2009, 13:41
Профиль
Супермодератор

Зарегистрирован: 01 окт 2008, 12:24
Сообщения: 4436
На рутере Х не всё шоколадно: с компа запрос прибежал (можно поглядеть на IGMPзапросы), поэтому появилась
(*,232.0.0.9), но RP он не видит, иначе была бы ещё запись

(10.10.0.1,232.0.0.9)

Сам с рутера Х 10.10.0.1 пингуется в этом VRFе?


19 май 2009, 15:01
Профиль

Зарегистрирован: 13 май 2009, 09:00
Сообщения: 4
Да, пингуется. Проверял.
Есть какие-нибудь предположения?


19 май 2009, 15:07
Профиль
Супермодератор

Зарегистрирован: 01 окт 2008, 12:24
Сообщения: 4436
А ежли другой RP (физический интерфейс) описать?


19 май 2009, 15:43
Профиль
Показать сообщения за:  Поле сортировки  
Ответить на тему   [ Сообщений: 6 ] 

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 31


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  
cron
Создано на основе phpBB® Forum Software © phpBB Group
Designed by ST Software for PTF.
Русская поддержка phpBB