Сообщения без ответов | Активные темы Текущее время: 04 июл 2020, 15:42



Ответить на тему  [ Сообщений: 7 ] 
L2TP 
Автор Сообщение

Зарегистрирован: 15 май 2009, 06:54
Сообщения: 25
Добрый день!
Поставили задачу сконфигурить туннель LT2P без шифрования на 871-2801. Поискал по ключевым слоавам, рабочих конфигов не нашел, есть только для задачи L2TP с IPSEC. Не поделитесь, где можно посмотреть рабочий пример, а то как то мало встретил описаний данной задачи на cisco.com :)


15 май 2009, 07:02
Профиль

Зарегистрирован: 13 май 2009, 13:19
Сообщения: 8
у меня IPSec и L2TP поднят между цыской и фряхой (на фряхе mpd запущен)
если надо могу поделиться.


15 май 2009, 09:02
Профиль

Зарегистрирован: 15 май 2009, 06:54
Сообщения: 25
Дело в том что мне нужна инкапсуляция l2tp без шифрования, если есть пример именно этого выложите цисковские настройки :)


15 май 2009, 10:03
Профиль
Супермодератор

Зарегистрирован: 01 окт 2008, 12:24
Сообщения: 4436
Конфиг не мой. Сам такой не пользовал - поэтому немного "плаваю". Утверждается, что конфиг рабочий

version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname client
!
!
logging message-counter syslog
logging buffered 1000000
!
no aaa new-model
!
!
dot11 syslog
ip source-route
!
!
!
!
ip cef
no ip domain lookup
no ipv6 cef
l2tp-class cisco
!
!
multilink bundle-name authenticated
!
!
!
!
!
crypto isakmp policy 10
encr aes 256
authentication pre-share
crypto isakmp key cisco address 0.0.0.0 0.0.0.0
!
!
crypto ipsec transform-set testtrans esp-des
!
crypto map vpn 10 ipsec-isakmp
set peer 10.48.67.132
set transform-set testtrans
match address vpn
!
archive
log config
hidekeys
!
!
pseudowire-class cisco
encapsulation l2tpv2
protocol l2tpv2 cisco
ip local interface FastEthernet0/0
!
!
!
!
interface Loopback2
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 10.48.67.122 255.255.254.0
duplex auto
speed auto
crypto map vpn
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Virtual-PPP1
ip address negotiated
ppp authentication chap callin
ppp chap hostname client
ppp chap password 0 cisco
pseudowire 10.48.67.132 10 pw-class cisco
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Virtual-PPP1
ip http server
no ip http secure-server
!
!
!
ip access-list extended vpn
permit udp host 10.48.67.122 eq 1701 host 10.48.67.132 eq 1701
!


В данном конфиге создаётся туннель на псевдоканальном уровне: с одной стороны - канальный уровень, с другой - виртуальный интерфейс РРР и туннельруется весь трафик в L2TP. Далее всё просто: весь выходящий трафик с 1701 на 1701 (l2tp) шифруется.

Если шифрование убрать (убрать crypto map на f0/0), то останется голый L2TP туннель


15 май 2009, 22:12
Профиль

Зарегистрирован: 13 май 2009, 13:19
Сообщения: 8
а я бы оставил crypto map int f0/0


18 май 2009, 07:59
Профиль

Зарегистрирован: 15 май 2009, 06:54
Сообщения: 25
Всем кто откликнулся, спасибо, вот кстате рабочий пример всё таки нарыл на циско ком
http://www.cisco.com/en/US/docs/ios/12_ ... #wp1027195


18 май 2009, 10:27
Профиль
Супермодератор

Зарегистрирован: 01 окт 2008, 12:24
Сообщения: 4436
Saratoga писал(а):
а я бы оставил crypto map int f0/0


Я бы тоже, но просили то без шифрования. Наверно, на то были причины :)


18 май 2009, 11:03
Профиль
Показать сообщения за:  Поле сортировки  
Ответить на тему   [ Сообщений: 7 ] 

Кто сейчас на конференции

Сейчас этот форум просматривают: Google [Bot] и гости: 29


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  
Создано на основе phpBB® Forum Software © phpBB Group
Designed by ST Software for PTF.
Русская поддержка phpBB