Сообщения без ответов | Активные темы Текущее время: 25 май 2020, 14:03



Эта тема закрыта, вы не можете редактировать и оставлять сообщения в ней.  [ Сообщений: 31 ]  На страницу 1, 2  След.
No Ringback tone 
Автор Сообщение

Зарегистрирован: 13 апр 2009, 11:00
Сообщения: 138
Всем привет! Столкнулся в общем, с известной проблемой - она обсуждалась уже ни раз на ввв.циско.ком, но тем не менее, решение проблемы я так и не нашел :(
Схема такая:
есть роутер циско 2821, на котором крутится CCME (циско колл манагер експресс).
Звонок с внешней линии послупает на роутер по h.323. Циска по SIP'у роутит его на АА - автосекретарь, который у меня поднят на AIM модуле. То есть это CUE (Cisco Unity Express). Далее автосекретарь предлагает донабрать номер, и если не набрали, то по тайм-ауту, переадресовывает звонок на секретаря..
то есть выглядит это так:
h.323 (g.729 codec) -> cisco2821 CUE (SIP, transcoding) -> Ip Phone 7940 (g,711 codec).
В общем, после переадресации звонка автосекретарем, телефон звонит, но звонящий в трубке наслаждается тишиной.. :(
Транскодинг включен. Я уже что только не пробовал. Таже перевёл один из внутненних телефонов на работу с g.729 кодеком и делал трансфер на него - все-равно гудка нет.
При чем, если звонок на роутер поступает не по h.323, а по аналоговой СО линии на FXO, то после обработки вызова автосекретарем, гудок слышен. И если звонок поступает по h.323, но при этом донабрать внутренний номер абонента, подключенного к FXS порту (то есть, обычный аналоговый телефон), то гудок так же слышен. Так же, если звонок маршрутизировать не через автосекретаря, а сразу на внутренний номер, то гудок тоже есть (звонок на внутренний номер 187 в конфиге ниже проходит нормально, с гудком).
Как решить эту проблему? В идеале вообще, хотелось бы подставлять вместо ringback tone приятную музычку...
Вроде, все понятно объяснил. Ниже приведу часть конфига, относящегося к настройкам входящих звонков..

Код:
!         
voice-card 0
 dspfarm 
 dsp services dspfarm
!
voice call send-alert
voice call disc-pi-off
voice call convert-discpi-to-prog
voice call carrier capacity active
voice call carrier csr reporting interval 10
voice rtp send-recv
!         
voice service pots
 supported-language ru
 supplementary-service qsig call-forward
!
!         
voice service voip
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 no supplementary-service h450.2
 no supplementary-service h450.3
 supplementary-service h450.12
 redirect ip2ip
 fax protocol t38 ls-redundancy 2 hs-redundancy 0 fallback cisco
 h323     
 sip     
  rel1xx supported "rel100"
  e911   
  header-passing
  registrar server
!         
!         
voice class codec 1
 codec preference 1 g729r8
 codec preference 2 g711ulaw
 codec preference 3 g711alaw
!         
!         
!         
!         
voice class h323 1
  call start slow
!         
!         
!         
voice class dualtone-detect-params 1
 freq-max-power 0
 freq-min-power 35
 freq-power-twist 15
 freq-max-delay 40
 cadence-variation 8
!         
!         
voice class custom-cptone 1
 dualtone disconnect
  frequency 430
  cadence 370 350
!         
!         
voip-incoming translation-rule called 10
!
!тут настраивается маршрутизация входящих вызовов. то есть пришедшие от оператора цифры номера
!подменяются на нужный внутренний номер. 500 - это номер автосекретаря. я просто решил обойтись без
!входящего диал-пира
translation-rule 10
 Rule 0 ^786ХХХХХХХ8 500
 Rule 1 ^786ХХХХХХХ9 500
 Rule 2 ^786ХХХХХХХ0 500
 Rule 3 ^786ХХХХХХХ1 187
!
!Интерфейс АДСЛ во внешний мир
interface ATM0/0/0
 mtu 1500
 bandwidth 8000
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip local-proxy-arp
 ip route-cache flow
 logging event atm pvc state
 logging event subif-link-status
 atm vc-per-vp 16384
 atm bandwidth dynamic
 no atm ilmi-keepalive
 dsl operating-mode adsl2+
 dsl lom 50
 dsl noise-margin 3
!         
interface ATM0/0/0.1 point-to-point
 bandwidth 8000
 bridge-group 1
 pvc 0/35
  vbr-rt 509 509 1
  no oam-pvc manage
  encapsulation aal5snap
  service-policy output POLICY
!
!
interface BVI1
 bandwidth 8000
 ip address 83.ХХХ.ХХХ.ХХ 255.255.255.252
 ip access-group 101 in
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip local-proxy-arp
 ip nat outside
 ip route-cache same-interface
 ip route-cache flow
 load-interval 30
 carrier-delay msec 0
 delay 1 
 keepalive 5
 h323-gateway voip interface
 h323-gateway voip id GK ipaddr 62.ХХХ.ХХХ.Х 1720
 h323-gateway voip h323-id HTS
 h323-gateway voip tech-prefix 1#
 h323-gateway voip bind srcaddr 83.ХХХ.ХХХ.ХХ
 hold-queue 150 in
!
ip route 0.0.0.0 0.0.0.0 BVI1
!
!Может быть, проблема из-за акцесс-листов? но тогда бы звонки напрямую, не через автосекретаря, тоже не
!выдавали бы гудка... На всякий случай, привожу акцесс-листы
ip http server
ip http access-class 10
ip http authentication local
no ip http secure-server
ip http path flash:
ip nat inside source list 1 interface BVI1 overload
ip nat inside source list 2 interface BVI1 overload
ip nat inside source static tcp 192.168.1.2 22 83.ХХХ.ХХХ.ХХ 22 extendable
ip nat inside source static tcp 192.168.1.3 25 83.ХХХ.ХХХ.ХХ 25 extendable
ip nat inside source static tcp 192.168.1.2 80 83.ХХХ.ХХХ.ХХ 80 extendable
ip nat inside source static tcp 192.168.1.2 443 83.ХХХ.ХХХ.ХХ 443 extendable
ip nat inside source static tcp 192.168.1.2 1723 83.ХХХ.ХХХ.ХХ 1723 extendable
!
access-list 1 permit 10.10.100.0 0.0.0.255
access-list 2 permit 192.168.1.0 0.0.0.255
access-list 100 remark Block outside access
access-list 100 permit ip 192.168.2.0 0.0.0.255 any
access-list 100 permit ip 10.10.100.0 0.0.0.255 any
access-list 100 deny   ip any any
access-list 101 deny   ip 192.168.0.0 0.0.255.255 any
access-list 101 deny   ip 127.0.0.0 0.255.255.255 any
access-list 101 deny   ip 10.0.0.0 0.255.255.255 any
access-list 101 deny   ip 172.16.0.0 0.15.255.255 any
access-list 101 deny   udp any eq netbios-dgm any
access-list 101 deny   udp any eq netbios-ns any
access-list 101 deny   udp any eq netbios-ss any
access-list 101 deny   tcp any eq 137 any
access-list 101 deny   tcp any eq 138 any
access-list 101 deny   tcp any eq 139 any
access-list 101 permit ip any any
!
!
control-plane
!
bridge 1 protocol ieee
bridge 1 route ip
!
ccm-manager music-on-hold
ccm-manager sccp local GigabitEthernet0/0.100
ccm-manager sccp
!
!
sccp local GigabitEthernet0/0.100
sccp ccm 10.10.100.1 identifier 1
sccp
!
sccp ccm group 1
 bind interface GigabitEthernet0/0.100
 associate ccm 1 priority 1
 associate profile 1 register transcode
 keepalive retries 5
 audio dscp cs5
!
!настройка транскодинга
dspfarm profile 1 transcode
 codec g729r8
 codec g729ar8
 codec g729abr8
 codec g711ulaw
 codec g711alaw
 rsvp
 maximum sessions 20
 associate application SCCP
!
!диал-пир для SIP-транка на автосекретаря (номер 500)
dial-peer voice 9001 voip
 tone ringback alert-no-PI
 description ** auto attendant **
 destination-pattern 500
 progress_ind setup enable 3
 progress_ind progress enable 8
 progress_ind connect enable 8
 delay transport-address
 session protocol sipv2
 session target ipv4:10.10.100.2
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
dial-peer voice 187 pots
 description To_Borovik
 destination-pattern 187$
 port 2/0/7
!
gateway   
 timer receive-rtp 1200
!         
!         
telephony-service
 video   
 srst ephone description 100 : Feb 13 2009 12:41:33
 srst dn line-mode dual
 no auto-reg-ephone
 fxo hook-flash
 load 7960-7940 P00308000500
 max-ephones 52
 max-dn 192
 ip source-address 10.10.100.1 port 2000
 calling-number initiator
 timeouts interdigit 20
 timeouts ringing 60
 system message HTS
 sdspfarm units 1
 sdspfarm transcode sessions 128
 sdspfarm tag 1 transcode
 url information http://10.10.100.1:80/GetTelecasterHelpText
 url directories http://10.10.100.1:80/localdirectory
 url services http://xmlphones.appspot.com/windows-1251/city/34929
 url authentication http://10.10.100.2/voiceview/authentication/authenticate.do
 cnf-file location flash:
 user-locale RU
 user-locale 1 RU
 user-locale 2 RU
 user-locale 3 RU
 user-locale 4 RU
 network-locale RU
 network-locale 1 RU
 network-locale 2 RU
 network-locale 3 RU
 network-locale 4 RU
 time-zone 32
 time-format 24
 date-format dd-mm-yy
 voicemail 555
 max-conferences 8 gain -6
 call-forward pattern .T
 call-forward pattern 7...
 moh music-on-hold.au
 multicast moh 239.1.1.1 port 2000
 web admin system name admin secret 5 $1$3.sn$wCY/VTby4PNWen0Un1
 dn-webedit
 time-webedit
 transfer-system full-consult
 transfer-pattern .T
 transfer-pattern 7... blind
 transfer-pattern 6...
 secondary-dialtone 9
 directory entry 1 124 name @srqnpqhmc
 directory entry 3 113 name Lndel
 fac standard
 create cnf-files version-stamp 7960 May 15 2009 19:32:44
!         


Ну, вот вроде бы, и весь код, относящийся к данной проблеме.
Помогите, пожалуйста, решить её. Уже не первый месяц бъюсь над ней :(


02 июн 2009, 10:13
Профиль

Зарегистрирован: 13 апр 2009, 11:00
Сообщения: 138
ну неужели ни кто ни когда с этим не сталкивался? :(


04 июн 2009, 09:02
Профиль
Супермодератор

Зарегистрирован: 01 окт 2008, 12:24
Сообщения: 4436
Я помочь не могу: переслал вопрос умным голосовикам. Наберемся терпения :)


04 июн 2009, 16:39
Профиль

Зарегистрирован: 13 апр 2009, 11:00
Сообщения: 138
Сергей (ведь ты же Сергей, верно? :) ) спасибо большое! Жду вестей с нетерпением, ибо уже два месяца бъюсь с этим :(


05 июн 2009, 08:25
Профиль

Зарегистрирован: 13 апр 2009, 11:00
Сообщения: 138
Ну что, проблему ни как нельзя решить, да? :(


11 июн 2009, 12:40
Профиль
Супермодератор

Зарегистрирован: 01 окт 2008, 12:24
Сообщения: 4436
Ещё один гуру по голосу попросил для полноты картины выложить вывод команды

sh voip rtp connection

в тот момент, когда абонент "наслаждается тишиной".

Он будет постараться сделать выводы и помочь:)


11 июн 2009, 13:13
Профиль

Зарегистрирован: 13 апр 2009, 11:00
Сообщения: 138
Да запросто! :)

Вот, что видно по команде sh voip rtp connection в тот момент, когда пришел вызов и трубку снял ATT на CUE (при звонке слышен один КПВ, а потом трубку снимает АТТ).
Код:
CCME#sh voip rtp connection
VoIP RTP active connections :
No. CallId     dstCallId  LocalRTP RmtRTP LocalIP         RemoteIP       
1   3527       3528       17596    23256  83.239.91.18    62.183.27.154 
2   3528       3527       18610    16906  10.10.100.1     10.10.100.2   
3   3530       3531       16620    2000   10.10.100.1     10.10.100.1   
4   3532       3531       16402    2000   10.10.100.1     10.10.100.1   
Found 4 active RTP connections


Если вы помните по конфигу выше, 83.239.91.18 - это айпишник нашего wan интерфейса. 62.183.27.154 - это айпи голосового шлюза.
10.10.100.1 и 10.10.100.2 это адреса CUE, на которых вертится АТТ.

А вот, что происходит, когда абонент произвоит донабор номера и АТТ маршрутизирует его на внутренного абонента и при этом звонящий слышит тишину, а телефон звонит:

Код:
CCME#sh voip rtp connection
VoIP RTP active connections :
No. CallId     dstCallId  LocalRTP RmtRTP LocalIP         RemoteIP       
1   3527       3528       17596    23256  83.239.91.18    62.183.27.154 
2   3528       3527       18610    16906  10.10.100.1     10.10.100.2   
Found 2 active RTP connections


По-моему, это как-то странно... Телефон находится в этой же подсети, но походу, на айпишник телефона не проключается rtp? Айпи телефона 10.10.100.38.


11 июн 2009, 13:34
Профиль

Зарегистрирован: 13 апр 2009, 11:00
Сообщения: 138
А вот что отображается, когда звонок кидается сразу на номер, не через автосекретаря, и гудок при этом слышен:
Код:
CCME#sh voip rtp connection
VoIP RTP active connections :
No. CallId     dstCallId  LocalRTP RmtRTP LocalIP         RemoteIP       
1   3624       3632       16860    24038  83.239.91.18    62.183.27.154 


Хотя, смотрите если звонок опять же напрявлять через автосекретаря, но не на IP Phone, а на обычный аналоговый телефон, подключенный к FXS, при этом гудок слышен, то вот что выдает:
Код:
4   3660       3659       17760    16906  10.10.100.1     10.10.100.2

То есть, тоже самое, что и при звонках на IP Phone.
Странно.
Вообще, Сергей, привлеки на форум побольше VoIP'ников. Вопросов еще мнооого будет интересных! ;)


11 июн 2009, 13:43
Профиль
Супермодератор

Зарегистрирован: 01 окт 2008, 12:24
Сообщения: 4436
Есть мнение, что не хватает обратного маршрута (или прямого) на интерфейсе service-engine

Киньтесь плз настройкой интерфейсов, в часности интерфейса service-engine

Там должна быть настройка, типа

Router(config)# interface Service-Engine 1/0
Router(config-if)# ip address 10.0.0.9 255.0.0.0
Router(config-if)# service-module ip address 10.0.0.10 255.0.0.0
Router(config-if)# service-module ip default-gateway 10.0.100.10
Router(config-if)# exit


11 июн 2009, 13:51
Профиль

Зарегистрирован: 13 апр 2009, 11:00
Сообщения: 138
Я подумал, что этой инфы недостаточно, потому приведу вывод команды sh voip rtp connections detail :

Код:
CCME#sh voip rtp connections detail
VoIP RTP active connections :
No. CallId     dstCallId  LocalRTP RmtRTP LocalIP         RemoteIP   
2   3684       3685       17846    31968  83.239.91.18    62.183.50.5   
 callId 3684 (dir=1): called=500 calling=9884608100 redirect=
     dest callId 3685: called=500 calling=9884608100 redirect=
   1 context 481C0140 xmitFunc 40B26BEC
3   3685       3684       16664    16904  10.10.100.1     10.10.100.2   
 callId 3685 (dir=2): called=500 calling=9884608100 redirect=
     dest callId 3684: called=500 calling=9884608100 redirect=
   1 context 480BAF40 xmitFunc 40B26BEC
4   3686       3687       17012    2000   10.10.100.1     10.10.100.1   
 callId 3686 (dir=2): called= calling= redirect=
     dest callId 3687: called= calling= redirect=
5   3688       3687       19382    2000   10.10.100.1     10.10.100.1   
 callId 3688 (dir=2): called= calling= redirect=
     dest callId 3687: called= calling= redirect=
Found 5 active RTP connections


Это когда звонок приходит на автосекретаря. Как видите, звонили с номера 9884608100, попадали на номер 500 (на нем и висит АТТ).

А вот это вывод команды, когда донабрали внутренний номер 121 и слушают тишину:

Код:
CCME#sh voip rtp connections detail
VoIP RTP active connections :
No. CallId     dstCallId  LocalRTP RmtRTP LocalIP         RemoteIP       
2   3684       3685       17846    31968  83.239.91.18    62.183.50.5   
 callId 3684 (dir=1): called=500 calling=9884608100 redirect=
     dest callId 3685: called=500 calling=9884608100 redirect=
3   3685       3684       16664    16904  10.10.100.1     10.10.100.2   
 callId 3685 (dir=2): called=500 calling=9884608100 redirect=
     dest callId 3684: called=500 calling=9884608100 redirect=
Found 3 active RTP connections


Хааа!!! Коллеги, а вот посмотрите теперь, что происходит, когда я звоню на автосекретаря и донабираю аналоговый номер 151 (когда я слышу гудок):
Код:
3   3716       3722       17024    26506  83.239.91.18    62.183.27.154 
 callId 3716 (dir=1): called=500 calling=9884608100 redirect=
     dest callId 3722: called=151 calling=9884608100 redirect=500
   1 context 4575AF60 xmitFunc 4161C8DC
4   3717       3716       19142    16900  10.10.100.1     10.10.100.2   
 callId 3717 (dir=2): called=500 calling=9884608100 redirect=
     dest callId 3716: called=500 calling=9884608100 redirect=
Found 4 active RTP connections

Как вы видите, в третей строчке кода появилась надпись called=151, когда как при звонке на номер 121, запись не менялась, и отображалось called=500...
Вот где, наверное, собака зарыта?


11 июн 2009, 14:01
Профиль

Зарегистрирован: 13 апр 2009, 11:00
Сообщения: 138
настройки этого интерфейса я уже писал, кажется ;) но на всякий случай, повторюсь:

Код:
interface Service-Engine0/0
interface GigabitEthernet0/0.100
 description voice
 encapsulation dot1Q 100
 ip address 10.10.100.1 255.255.255.0
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip pim dense-mode
 ip nat inside
!
 ip unnumbered GigabitEthernet0/0.100
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip route-cache flow
 service-module ip address 10.10.100.2 255.255.255.0
 service-module ip default-gateway 10.10.100.1

ip route 0.0.0.0 0.0.0.0 BVI1
ip route 10.10.100.2 255.255.255.255 Service-Engine0/0


вроде, совпадает с тем, что ты написал ;)


11 июн 2009, 14:04
Профиль
Супермодератор

Зарегистрирован: 01 окт 2008, 12:24
Сообщения: 4436
Да, на интерфейсе и в маршрутизации вроде все в порядке.

ЗЫ Убегаю. Вечером ещё поглядим.


11 июн 2009, 14:10
Профиль

Зарегистрирован: 13 апр 2009, 11:00
Сообщения: 138
очень жду ;) только на тебя вся и надежда ;) уже не знаю где и куда мне дальше ковырять. Но, судя по всему, проблема действительно с некорректной маршрутизацией где-то.. Раз в RTP не отображается звонок на номер...


11 июн 2009, 14:23
Профиль

Зарегистрирован: 11 июн 2009, 14:25
Сообщения: 2
А не пробовали сменить на циске IOS на более новый, или наоборот на более старый ?
Желательно на тот, где Вы точно уверены что подобное работает ....


11 июн 2009, 14:35
Профиль

Зарегистрирован: 11 июн 2009, 14:42
Сообщения: 3
Еще момент: попробуйте привязать sip сигнализацию к гигабитному интерфейсу явно.
voice service voip
sip
bind bla-bla-bla


11 июн 2009, 14:45
Профиль

Зарегистрирован: 11 июн 2009, 14:42
Сообщения: 3
и еще дайте пожалуйста вывод команды sh voice call st


11 июн 2009, 14:52
Профиль

Зарегистрирован: 13 апр 2009, 11:00
Сообщения: 138
Ales999 ИОС пока меня не пробовал, но уже пришёл к выводу, что проблема, возможно, может быть в нем. Попробую решить этот вопрос на неделе.
Но, для начала, воспользуюсь рекомендацией mike_sk1974. Но я смогу это сделать только в понедельник.
Как сделаю - отпишусь ;)


13 июн 2009, 00:46
Профиль

Зарегистрирован: 13 апр 2009, 11:00
Сообщения: 138
Привет!
Это снова я!
В общем, прописал я строчку: bind all source-interface gigabitEthernet 0/0.100, но она в конфиге не отобразилась :(

Код:
voice service voip
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 no supplementary-service h450.2
 no supplementary-service h450.3
 supplementary-service h450.12
 redirect ip2ip
 fax protocol t38 ls-redundancy 2 hs-redundancy 0 fallback cisco
 h323
 sip
  rel1xx supported "rel100"
  min-se  90
  ds0-num
  e911
  header-passing
  registrar server
  transport switch udp tcp


А вот если прописать bind media source-interface gigabitEthernet 0/0.100, то эта строчка отображается, но вызов при этом автосекретарем не обрабатывается.
А если прописать bind media source-interface gigabitEthernet 0/0, то автосекретарь берет трубку, но проблема остается та же.

А вот вывод команды sh voice call st:
В момент, когда звонок пришел на автосекретаря и донабор не был еще произведен, по этой команде почему-то ни чего не отображается.
А когда делаю донабор на номер 121, то отображается следующее:

Код:
CCME#sh voice call st
CallID     CID  ccVdb      Port        DSP/Ch  Called #   Codec     Dial-peers
0x1939     6F5  0x4717CD0C 50/0/10.0          *121        g729r8    1000/20010


А вот звонок на FXS номер, когда гудок слышен:

Код:
CCME#sh voice call st
CallID     CID  ccVdb      Port        DSP/Ch  Called #   Codec     Dial-peers
0x195D     848  0x46CEA6A8 2/0/4       0/1:1  *151        g729r8    1000/151


15 июн 2009, 09:09
Профиль

Зарегистрирован: 13 апр 2009, 11:00
Сообщения: 138
В общем, пока не работает... Проблема в силе. Если до конца недели ни каких вариантов не будет, то остается только менять ИОС. Что довольно проблематично.. Но ни чего не поделаешь ;)


15 июн 2009, 09:12
Профиль

Зарегистрирован: 13 апр 2009, 11:00
Сообщения: 138
Народ, НИИИД ХЕЕЕЕЛП!!!! А-аааа! :)


15 июн 2009, 18:14
Профиль
Супермодератор

Зарегистрирован: 01 окт 2008, 12:24
Сообщения: 4436
Может странную вещь скажу, но мысль пришла и уйти не желает:

вы интерфейс service-engine примапили к интерфейсу g0/0.100, т.е. к тэгированному интерфейсу...

А сам CUE, что то мне подсказывает, шлёт нетегированный трафик. Может быть с интерфейса убегает нетегированный фрейм вместо тэгированного? МОжно ли попробовать переконфигурить так, как в доке, не используя подынтерфейсов?

Дока: http://www.cisco.com/en/US/docs/voice_ip_comm/unity_exp/rel1_1_2/ccm_cli/ch2instl.html#wp1093101


15 июн 2009, 21:54
Профиль

Зарегистрирован: 13 апр 2009, 11:00
Сообщения: 138
Сергей, по-моему, это не получится. Прописать IP-адрес той же подсети, что и на Gi0/0.100 я не могу. А если прописываю IP другой подсети, например, 10.10.10.1/24, то CUE перестает работать. наверное, надо будет менять service-module ip address... А это повлечет за собой смену маршрутов и вообще :)
Кстати, звонок по h.323 приходит с BVI интерфейса:
Код:
interface BVI1
 bandwidth 8000
 ip address 83.239.91.18 255.255.255.252
 ip access-group 101 in
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip local-proxy-arp
 ip nat outside
 ip route-cache same-interface
 ip route-cache flow
 load-interval 30
 carrier-delay msec 0
 delay 1
 keepalive 5
 h323-gateway voip interface
 h323-gateway voip id GK ipaddr 62.183.50.5 1720
 h323-gateway voip h323-id HTS
 h323-gateway voip tech-prefix 1#
 h323-gateway voip bind srcaddr 83.239.91.18
 hold-queue 150 in


А попадает на телефоны, которые на Gi0/0.100, который тегированный. И ringback tone есть.. А нету его, если идет через service-engine.. По сути - одно и то же?
Воипники ни чего больше не могут подсказать?


16 июн 2009, 09:39
Профиль

Зарегистрирован: 13 апр 2009, 11:00
Сообщения: 138
Сергей, ну что мне делать-то? :)
Вы - моя последняя надежда на спасение :)))
Сегодня буду искать версию иос, которую поддерживает мой маршрутизатор. Может, обновление поможет.. ;)


17 июн 2009, 09:46
Профиль

Зарегистрирован: 11 июн 2009, 14:42
Сообщения: 3
когда идет вывод sh voice call status, не совсем понятно, что за входящий dial-peer 1000 отображается? Он у Вас в конфиге есть?


17 июн 2009, 14:04
Профиль

Зарегистрирован: 13 апр 2009, 11:00
Сообщения: 138
Да, есть!
Вот список всех диал-пиров:

Код:
dial-peer voice 9000 voip
 mailbox-selection last-redirect-num
 description ** voicemail pilot number **
 destination-pattern 555
 session protocol sipv2
 session target ipv4:10.10.100.2
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
dial-peer voice 9001 voip
 tone ringback alert-no-PI
 description ** auto attendant **
 destination-pattern 500
 progress_ind setup enable 3
 progress_ind progress enable 8
 progress_ind connect enable 8
 delay transport-address
! эти заморочки с rtp их не было раньше - просто это я игрался, пытаясь решить проблему.
 rtp payload-type cisco-pcm-switch-over-ulaw 126
 rtp payload-type cisco-rtp-dtmf-relay 98
 rtp payload-type g726r16 dynamic
 session protocol sipv2
 session target ipv4:10.10.100.2
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
dial-peer voice 112 pots
 description To_FAX
 destination-pattern 112
 port 2/0/0
!
dial-peer voice 113 pots
 description To_MODEM
 destination-pattern 113
 port 2/0/1
!
dial-peer voice 124 pots
 description To_AUTSORING
 destination-pattern 124
 port 2/0/2
!
dial-peer voice 126 pots
 description To_Fomenko
 service stcapp
 port 2/0/3
!
dial-peer voice 151 pots
 description To_Chepel
 service stcapp
 port 2/0/4
!
dial-peer voice 1000 voip
 description Voip_To_City
 preference 1
 destination-pattern 9[2-7,9]......
 translate-outgoing called 2
 voice-class codec 1
 session target ipv4:62.183.50.5
 dtmf-relay h245-alphanumeric
 fax protocol cisco
 ip qos dscp cs5 media
 no vad
!
dial-peer voice 1001 voip
 description Voip_To_Mobile&Mezhgorod
 preference 1
 destination-pattern 98..........
 translate-outgoing called 1
 voice-class codec 1
 session target ipv4:62.183.50.5
 dtmf-relay h245-alphanumeric
 fax protocol cisco
 ip qos dscp cs5 media
 no vad
!
dial-peer voice 1010 pots
 trunkgroup ALL_Outgoing
 description To_PSTN_City
 preference 10
 destination-pattern 9[2-7,9]......
!
dial-peer voice 1011 pots
 trunkgroup ALL_Outgoing
 description Mobile_Mezhgorod
 preference 10
 destination-pattern 9...........
!
dial-peer voice 1015 pots
 trunkgroup CO1
 corlist incoming in
 corlist outgoing 81
 destination-pattern 81[2-7]......
!
dial-peer voice 1016 pots
 trunkgroup CO1
 corlist incoming in
 corlist outgoing 81
 destination-pattern 81...........
!
dial-peer voice 1017 pots
 corlist incoming in
 corlist outgoing 81
 destination-pattern 82[2-7]......
 port 2/0/9
!
dial-peer voice 1020 pots
 trunkgroup CO4
 description To_PSTN
 destination-pattern 6...
!
dial-peer voice 1 voip
 incoming called-number 800[0,1]...
 codec g711ulaw
 no vad
!
dial-peer voice 10000 voip
 preference 7
 destination-pattern 7...
 translate-outgoing called 3
 voice-class sip dtmf-relay force rtp-nte
 session protocol sipv2
 session target ipv4:192.168.2.7
 session transport tcp
 dtmf-relay rtp-nte
 codec g711ulaw
 clid strip name
 no vad
!
dial-peer voice 9002 voip
 destination-pattern 505
 session protocol sipv2
 session target ipv4:10.10.100.2
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
dial-peer voice 1002 voip
 description Voip_Emergency
 destination-pattern 0[1-49]
 session target ipv4:62.183.50.5
 dtmf-relay h245-alphanumeric
 codec g729r8 bytes 40
 fax protocol cisco
 ip qos dscp cs5 media
 no vad
!
dial-peer voice 175 pots
 description To_Bin
 service stcapp
 port 2/0/6
!
dial-peer voice 187 pots
 description To_Borovik
 service stcapp
 port 2/0/7
!
dial-peer voice 1003 voip
 description Voip_Emergency_2
 destination-pattern 0..
 session target ipv4:62.183.50.5
 dtmf-relay h245-alphanumeric
 codec g729r8 bytes 40
 fax protocol cisco
 ip qos dscp cs5 media
 no vad
!
dial-peer voice 1018 pots
 corlist incoming in
 corlist outgoing 81
 mailbox-selection orig-called-num
 destination-pattern 82...........
 port 2/0/9
!
dial-peer voice 9003 voip
 tone ringback alert-no-PI
 description ** auto attendant **
 destination-pattern 502
 progress_ind setup enable 3
 progress_ind progress enable 8
 progress_ind connect enable 8
 progress_ind disconnect enable 8
 delay transport-address
 session protocol sipv2
 session target ipv4:10.10.100.2
 dtmf-relay sip-notify
 codec g711ulaw
!
dial-peer voice 9006 voip
 description Alarm script
 service alarm
 destination-pattern ^66$
 session protocol sipv2
 session target ipv4:192.168.2.250
 incoming called-number ^66$
 dtmf-relay rtp-nte
 codec g711ulaw
 no vad
!
!

На всякий случай еще кусок конфига:

Код:
ccm-manager music-on-hold
ccm-manager sccp local GigabitEthernet0/0.100
ccm-manager sccp
!
!
sccp local GigabitEthernet0/0.100
sccp ccm 10.10.100.1 identifier 1 version 4.1
sccp ip precedence 1
sccp
!
sccp ccm group 1
 bind interface GigabitEthernet0/0.100
 associate ccm 1 priority 1
 associate profile 1 register transcode
 keepalive retries 5
 switchback method graceful
 signaling dscp ef
!
dspfarm profile 1 transcode
 codec g729r8
 codec g729ar8
 codec g729abr8
 codec g711ulaw
 codec g711alaw
 rsvp     
 maximum sessions 20
 associate application SCCP
!
voice class codec 1
 codec preference 1 g729r8
 codec preference 2 g711ulaw
 codec preference 3 g711alaw


17 июн 2009, 15:34
Профиль
Показать сообщения за:  Поле сортировки  
Эта тема закрыта, вы не можете редактировать и оставлять сообщения в ней.   [ Сообщений: 31 ]  На страницу 1, 2  След.

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 4


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  
Создано на основе phpBB® Forum Software © phpBB Group
Designed by ST Software for PTF.
Русская поддержка phpBB