Сообщения без ответов | Активные темы Текущее время: 16 июл 2020, 20:13



Ответить на тему  [ Сообщений: 7 ] 
ip nat enable and route-map 
Автор Сообщение

Зарегистрирован: 01 янв 1970, 03:00
Сообщения: 4526
Изображение

R5

interface FastEthernet0/0
ip address 192.168.0.2 255.255.255.0
ip nat enable
interface FastEthernet0/1
ip address 192.1.1.1 255.255.255.0
ip nat enable
ip nat pool OUTIN 192.168.0.2 192.168.0.2 prefix-length 24
ip nat source route-map OUTIN pool OUTIN overload
ip access-list extended OUTIN
permit ip host 192.168.2.2 host 192.1.1.2
deny ip any any
route-map OUTIN permit 10
match ip address OUTIN

Проблема:
При пинге с 192.1.1.2 на 192.168.2.2, IP 192.1.1.2 преобразуется в 192.168.0.2.

Решение:
Добавить в oute-map OUTIN permit 10 следующую строчку - match int f0/0.

Вопрос:
Почему несмотря на то что в route-map явно указано направление с 192.168.2.2 на 192.1.1.2
Трансляция происходит в обе стороны?


24 авг 2010, 09:11
Профиль

Зарегистрирован: 01 янв 1970, 03:00
Сообщения: 4526
Вопрос 2:
Что будет раньше срабатывать? И если сработало одно, то будет ли срабатывать следующее правило?

Ситуация 1:
ip nat source route-map INOUT pool INOUT overload

ip nat inside source list 101 interface FastEthernet0/0 overload

Ситуация 2:
ip nat source route-map OUTIN pool OUTIN overload

ip nat source static 192.1.1.2 192.168.1.1


24 авг 2010, 09:46
Профиль
Супермодератор

Зарегистрирован: 01 окт 2008, 12:24
Сообщения: 4436
ip nat inside source
вообще не должен сработать...


24 авг 2010, 10:09
Профиль

Зарегистрирован: 01 янв 1970, 03:00
Сообщения: 4526
То есть срабатывает всегда ip nat source? И cisco переходит к следующему этапу?
А в Ситуации 2 меняются разные IP в одном случае Destination в другом случае Source.

Добавление в route-map OUTIN permit 10 следующей строчки - match int f0/0.
Решило только проблему с пингом 192.1.1.2 на 192.168.2.2
Но при пинге с 192.168.2.2 на 192.1.1.2 не происходит замены 192.168.2.2 на 192.168.0.2.

Если убрать match int f0/0, то замена 192.168.2.2 на 192.168.0.2 происходит, но с 192.1.1.2 на 192.168.2.2 не пингуется, т.к. зацикливается:
1 192.168.1.1 35 мс
2 192.168.0.2 51 мс
3 *
4 192.168.0.2 99 мс


24 авг 2010, 10:13
Профиль

Зарегистрирован: 01 янв 1970, 03:00
Сообщения: 4526
Странно но пока решение проблемы - использование NAT:

ip nat pool INOUT 192.1.1.1 192.1.1.1 prefix-length 24
ip nat source route-map INOUT pool INOUT overload


Есть ли способ устранить данную проблему, не используя NAT?


24 авг 2010, 10:43
Профиль

Зарегистрирован: 20 окт 2009, 18:55
Сообщения: 962
если правильно написать, срабатывают оба. что раньше - не знаю, не пробовал.


24 авг 2010, 17:46
Профиль

Зарегистрирован: 01 янв 1970, 03:00
Сообщения: 4526
Срабатывает последним NVI.

Вопрос про NVI снят:
Ответный пакет подпадает под ACL.

Тему можно закрыть :)


25 авг 2010, 13:18
Профиль
Показать сообщения за:  Поле сортировки  
Ответить на тему   [ Сообщений: 7 ] 

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 3


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  
Создано на основе phpBB® Forum Software © phpBB Group
Designed by ST Software for PTF.
Русская поддержка phpBB