Сообщения без ответов | Активные темы Текущее время: 14 ноя 2019, 11:49



Ответить на тему  [ Сообщений: 10 ] 
NAT между интерфейсами 
Автор Сообщение

Зарегистрирован: 27 июн 2015, 14:29
Сообщения: 30
Возникла тут задача но что то в растерянности как реализовать.
Нужно сделать двухсторонний NAT между организациями.
Имеется в наличии cisco isr 4321 и связь между организациями оптика.
Куда в данной задаче вешать то ip nat inside ip nat outside ?


п.с. Маршрутизацию не предлагать есть нюансы.


Вложения:
nat.jpg
nat.jpg [ 10.96 КБ | Просмотров: 820 ]
04 окт 2019, 05:21
Профиль

Зарегистрирован: 10 окт 2012, 09:51
Сообщения: 2678
а зачем двухстороний? Может хватит натить одну сеть?


04 окт 2019, 07:09
Профиль

Зарегистрирован: 07 сен 2014, 02:54
Сообщения: 297
Откуда: Moscow
djakson писал(а):
Маршрутизацию не предлагать есть нюансы.

А может вы опишете исходную задачу? С нюансами.

_________________
Knowledge is Power


04 окт 2019, 07:35
Профиль

Зарегистрирован: 12 июл 2012, 17:44
Сообщения: 697
И роутинг всё равно будет, даже если и с NAT. :-)


04 окт 2019, 10:31
Профиль

Зарегистрирован: 27 июн 2015, 14:29
Сообщения: 30
Вроде нашел ответ.

Router(config-if)# ip nat enable
Router(config)# access-list 101 permit ip 10.0.2.0 0.0.0.255 10.0.1.0 0.0.0.255
Router(config)# access-list 102 permit ip 10.0.3.0 0.0.0.255 10.0.2.0 0.0.0.255
Router(config)# ip nat source list 101 interface fa 0/0 overload
Router(config)# ip nat source list 102 interface fa 0/1 overload

Сегодня попробую в CPT.


04 окт 2019, 11:17
Профиль

Зарегистрирован: 10 июл 2019, 18:21
Сообщения: 57
какая задача стоит, что решено было остановиться на double nat?

конфиг должен быть рабочим, но еще nat прописывается на конкретном интерфейсе

http://www.routereflector.com/2017/02/t ... co-router/

interface Ethernet0/0
ip address 1.1.1.2 255.255.255.252
ip nat outside
interface Ethernet0/1
ip address 10.255.255.1 255.255.255.0
ip nat inside


04 окт 2019, 12:19
Профиль

Зарегистрирован: 27 июн 2015, 14:29
Сообщения: 30
В этих филиалах есть свои удаленные подключения предоставляемые провайдером оптикой и статическими ip на концах
и которые соединены коммутаторами L3 и поднята маршрутизация средствами SVI. На оконечном оборудовании прописаны маршруты.
Сейчас всё работает на linux iptables но решили заменить на железку. Пробовал на mikrotik - но он под нагрузкой дохнет.
Из разных филиалов ходят как в локальные сети так и в сети за коммутаторами.


04 окт 2019, 12:56
Профиль

Зарегистрирован: 07 сен 2014, 02:54
Сообщения: 297
Откуда: Moscow
Пока единственный нюанс, который видно, это неумение настроить маршрутизацию.
И поэтому решили нафигачить NAT-а.

_________________
Knowledge is Power


04 окт 2019, 16:52
Профиль

Зарегистрирован: 10 июл 2019, 18:21
Сообщения: 57
djakson писал(а):
В этих филиалах есть свои удаленные подключения предоставляемые провайдером оптикой и статическими ip на концах
и которые соединены коммутаторами L3 и поднята маршрутизация средствами SVI. На оконечном оборудовании прописаны маршруты.
Сейчас всё работает на linux iptables но решили заменить на железку. Пробовал на mikrotik - но он под нагрузкой дохнет.
Из разных филиалов ходят как в локальные сети так и в сети за коммутаторами.


Так тут не в нате дело тогда. Нат это не роутинг же. Тут проблема именно в железке посередине. Нарисуйте подробнее схему и что-куда роутится.


04 окт 2019, 18:36
Профиль

Зарегистрирован: 07 сен 2014, 02:54
Сообщения: 297
Откуда: Moscow
Praporwik писал(а):
Тут проблема именно в железке посередине.
Нарисуйте подробнее схему и что-куда роутится.

Проблема не в железке, а "в головах".
Скорее всего она тут совсем не нужна.
Оптический L2 линк можно пробросить напрямую между удаленными роутерами.
Ну и настроить между ними маршрутизацию соответственно.

_________________
Knowledge is Power


04 окт 2019, 18:43
Профиль
Показать сообщения за:  Поле сортировки  
Ответить на тему   [ Сообщений: 10 ] 

Кто сейчас на конференции

Сейчас этот форум просматривают: Google [Bot] и гости: 21


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  
Создано на основе phpBB® Forum Software © phpBB Group
Designed by ST Software for PTF.
Русская поддержка phpBB