Сообщения без ответов | Активные темы Текущее время: 22 ноя 2019, 15:38



Ответить на тему  [ Сообщений: 3 ] 
IPTV Multicast + ASA + L3 Switch 
Автор Сообщение

Зарегистрирован: 10 ноя 2012, 22:34
Сообщения: 26
Здравствуйте, дома провайдер предоставляет услуга АЙПИТВ
При следующих настройках на АСАШКЕ, приставка подключена в ИНСАЙД - все норм:

multicast-routing

interface GigabitEthernet0/0
nameif OUTSIDE
security-level 0
ip address dhcp setroute
igmp access-group OUTSIDE_MULTICAST

interface GigabitEthernet0/1
nameif INSIDE
security-level 100
ip address 192.168.19.1 255.255.255.248
igmp limit 5
igmp forward interface OUTSIDE
igmp query-timeout 60
igmp query-interval 20
igmp access-group INSIDE_MULTICAST

access-list OUTSIDE_MULTICAST standard permit 225.77.0.0 255.255.0.0
access-list INSIDE_MULTICAST standard permit 225.77.0.0 255.255.0.0

mroute 0.0.0.0 0.0.0.0 77.37.158.1


Я вижу что приставка подключается к необходимым группам

AP-ASA5520# sh igmp groups
IGMP Connected Group Membership
Group Address Interface Uptime Expires Last Reporter
225.77.22.21 INSIDE 00:00:40 00:00:48 192.168.19.5

И появляются соответствующие маршруты:

AP-ASA5520# sh mroute

Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group,
C - Connected, L - Local, I - Received Source Specific Host Report,
P - Pruned, R - RP-bit set, F - Register flag, T - SPT-bit set,
J - Join SPT
Timers: Uptime/Expires
Interface state: Interface, State

(*, 225.77.22.21), 00:00:38/never, RP 0.0.0.0, flags: DC
Incoming interface: Null
RPF nbr: 0.0.0.0
Immediate Outgoing interface list:
INSIDE, Forward, 00:00:38/never

(198.18.8.2, 225.77.22.21), 00:00:38/00:03:29, flags: DJT
Incoming interface: OUTSIDE
RPF nbr: 77.37.158.1
Inherited Outgoing interface list:
INSIDE, Forward, 00:00:38/never


Теперь возникла осознанная необходимость поставить между приставкой и асашкой Л3 свич.
Коммутатор = 3560X / ipservices

На свиче пробовал следующие варианты:

ip multicast-routing distributed

int Vlan4
description IPTV
ip pim sparse-dense-mode
- или ip pim sparse mode
- или ip pim dense-dense

Если спарс режим, добавлял на свиче
ip pim rp-address 192.168.19.1 override (ВНУТРЕННИЙ АДРЕС АСАШКИ)
на асашке при этом убирал igmp forward interface OUTSIDE
и добавлял pim rp-address 192.168.19.1
при этом аса и свич видят друг друга (sh ip pim neighbor)

Но приставка не работает (((
Когда я переключаю каналы на приставке, я вижу на свиче что она обращается к необходимым адресам (sh ip igmp neighbor), но через некоторые время сессия рвется
В то же время на асе во время этих переключений я не вижу ни mroute ни igmp группы

Подскажите, как это настроить?


06 фев 2019, 16:40
Профиль

Зарегистрирован: 09 сен 2017, 11:15
Сообщения: 77
Откуда: Default City
И не будет.

Все дело в том, что провайдер Вам предоставляет уже L2 multicast. ASA же просто проксирует IGMP клиента на Outside интерфейс. IGMP является протоколом "последней мили", т.е. дальше PIM уже не поднимается.

_________________
@k@ fantik


03 мар 2019, 23:08
Профиль

Зарегистрирован: 10 ноя 2012, 22:34
Сообщения: 26
1. Спасибо!
2. То есть нет возможности смаршрутизировать igmp травик внутри моей сетки ? Через Л3?


03 мар 2019, 23:15
Профиль
Показать сообщения за:  Поле сортировки  
Ответить на тему   [ Сообщений: 3 ] 

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 21


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  
Создано на основе phpBB® Forum Software © phpBB Group
Designed by ST Software for PTF.
Русская поддержка phpBB