Сообщения без ответов | Активные темы Текущее время: 20 сен 2019, 19:37



Ответить на тему  [ Сообщений: 8 ] 
Пожалуйста, помогите настроить доступ в интернет. 
Автор Сообщение

Зарегистрирован: 10 сен 2019, 01:10
Сообщения: 3
Здравствуйте, уважаемые форумчане! Прошу Вас о помощи в базовой настройке роутера Cisco 881w. В технике Cisco я новичок и прошу прощения, если допустил какую-то глупую ошибку. Настраиваю роутер для домашнего использования, получаю ip по DHCP от провайдера.
Составлял конфигурацию по примерам в интернете, но успехом мои попытки не увенчались. Вместо нормального доступа в интернет имею ряд странных симптомов, причины которых мне не ясны по причине отсутствия знаний и опыта: роутер может пинговать интернет, но не может пинговать собственный ip, полученный от провайдера. Сервер подключенный к роутеру не может пинговать даже DNS, хотя при попытке пингануть Google - определяет его ip. При этом я могу подключиться к северу по SSH из-вне сети. Заранее благодарю за потраченное время.

Мой конфиг:

Using 5026 out of 262136 bytes
!
! Last configuration change at 10:08:30 Ukraine Thu Sep 12 2019 by tarma
!
version 15.0
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname 881w
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
!
aaa new-model
!
!
aaa authentication login default local
!
!
!
!
!
aaa session-id common
!
!
!
memory-size iomem 10
clock timezone Ukraine 2
clock summer-time Ukraine recurring last Sun Mar 2:00 last Sun Oct 2:00
service-module wlan-ap 0 bootimage autonomous
!
crypto pki trustpoint TP-self-signed-350739132
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-350739132
revocation-check none
rsakeypair TP-self-signed-350739132
!
!
crypto pki certificate chain TP-self-signed-350739132
certificate self-signed 01 nvram:IOS-Self-Sig#13.cer
no ip source-route
!
!
ip dhcp excluded-address 10.10.10.1 10.10.10.10
!
ip dhcp pool LAN
import all
network 10.10.10.0 255.255.255.0
default-router 10.10.10.1
dns-server 8.8.8.8
!
!
ip cef
no ip bootp server
ip domain name router.domain
ip name-server 8.8.8.8
ip name-server 4.4.2.2
ip name-server 4.2.2.2
no ipv6 cef
!
!
multilink bundle-name authenticated
license udi pid CISCO881W-GN-E-K9 sn FCZ1603C1WM
license boot module c880-data level advipservices
!
!
archive
log config
logging enable
hidekeys
username TARMA privilege 15 secret 5 $1$a4P9$KtZvDFSyU2B6aPTbdUK7p0
!
!
ip ssh time-out 60
ip ssh authentication-retries 2
ip ssh version 2
!
!
!
!
!
!
!
interface FastEthernet0
!
!
interface FastEthernet1
!
!
interface FastEthernet2
!
!
interface FastEthernet3
!
!
interface FastEthernet4
description ===Internet===
ip address dhcp
no ip redirects
no ip unreachables
no ip proxy-arp
ip verify unicast reverse-path
ip flow ingress
ip nat outside
ip virtual-reassembly
no ip route-cache cef
no ip route-cache
duplex full
speed 100
no cdp enable
!
!
interface wlan-ap0
description Service module interface to manage the embedded AP
ip unnumbered Vlan1
arp timeout 0
!
!
interface Wlan-GigabitEthernet0
description Internal switch interface connecting to the embedded AP
!
!
interface Vlan1
description ===LAN===
ip address 10.10.10.1 255.255.255.248
no ip redirects
no ip unreachables
no ip proxy-arp
ip accounting output-packets
ip flow ingress
ip nat inside
ip virtual-reassembly
no ip route-cache cef
no ip route-cache
ip tcp adjust-mss 1452
!
!
ip forward-protocol nd
no ip http server
ip http access-class 23
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
ip dns server
ip nat inside source list NAT interface FastEthernet4 overload
ip nat inside source static tcp 10.10.10.4 22 212.X.XX.XXX 22 extendable
!
ip access-list extended FIREWALL
permit tcp any any eq 22
ip access-list extended NAT
permit ip any any
permit ip host 10.10.10.1 any
!
no cdp run

!
!
!
!
!
control-plane
!
!
banner exec ^C
% Password expiration warning.


12 сен 2019, 09:40
Профиль

Зарегистрирован: 01 янв 1970, 03:00
Сообщения: 816
TARMA писал(а):
ip access-list extended NAT
permit ip any any
permit ip host 10.10.10.1 any

ну как минимум переделайте этот ACL
Код:
ip access-list extended NAT
permit ip 10.10.10.0 0.0.0.255 any


12 сен 2019, 09:52
Профиль

Зарегистрирован: 10 сен 2019, 01:10
Сообщения: 3
aliotru писал(а):
TARMA писал(а):
ip access-list extended NAT
permit ip any any
permit ip host 10.10.10.1 any

ну как минимум переделайте этот ACL
Код:
ip access-list extended NAT
permit ip 10.10.10.0 0.0.0.255 any


Большое спасибо за ответ! Внес правки, которые Вы предложили, однако, пока что, я все равно не могу пинговать интернет.


12 сен 2019, 10:04
Профиль

Зарегистрирован: 29 май 2017, 21:19
Сообщения: 767
у вас DHCP pool network 10.10.10.0 255.255.255.0 на всю подсеть /24

А на LAN интерфейсе маска /29 - ip address 10.10.10.1 255.255.255.248

И нет у вас маршрута по умолчанию

ip route 0.0.0.0 0.0.0.0 dhcp


12 сен 2019, 10:13
Профиль

Зарегистрирован: 10 сен 2019, 01:10
Сообщения: 3
root99 писал(а):
у вас DHCP pool network 10.10.10.0 255.255.255.0 на всю подсеть /24

А на LAN интерфейсе маска /29 - ip address 10.10.10.1 255.255.255.248

И нет у вас маршрута по умолчанию

ip route 0.0.0.0 0.0.0.0 dhcp


Прошу прощения, ввел команду no ip address 10.10.10.1 255.255.255.248 на интерфейсе и отвалилась сеть XD Не подумал об этом) Настраивал по SSH, сейчас прямого доступа к роутеру нет. Сообщу результат позже. Спасибо Вам еще раз!


12 сен 2019, 11:09
Профиль

Зарегистрирован: 14 мар 2012, 15:48
Сообщения: 221
попросите - девочку нажать на кнопочку - и планируйте ребут на 10-15 минут если не знаете что творите.


13 сен 2019, 10:32
Профиль

Зарегистрирован: 10 июл 2019, 18:21
Сообщения: 32
TARMA писал(а):
root99 писал(а):
у вас DHCP pool network 10.10.10.0 255.255.255.0 на всю подсеть /24

А на LAN интерфейсе маска /29 - ip address 10.10.10.1 255.255.255.248

И нет у вас маршрута по умолчанию

ip route 0.0.0.0 0.0.0.0 dhcp


Прошу прощения, ввел команду no ip address 10.10.10.1 255.255.255.248 на интерфейсе и отвалилась сеть XD Не подумал об этом) Настраивал по SSH, сейчас прямого доступа к роутеру нет. Сообщу результат позже. Спасибо Вам еще раз!


на это случай есть волшебная команда reload in ... - если потеряете управление роутер перезагрузится через указанное количество минут. я, обычно, ставлю 15-20 минут, иногда 30.


15 сен 2019, 14:57
Профиль

Зарегистрирован: 10 июл 2019, 18:21
Сообщения: 32
TARMA писал(а):
Здравствуйте, уважаемые форумчане! Прошу Вас о помощи в базовой настройке роутера Cisco 881w.


http://xgu.ru/wiki/Cisco_871

если надо, могу скинуть конфиги с рабочих 880-х роутеров для примера.


15 сен 2019, 15:00
Профиль
Показать сообщения за:  Поле сортировки  
Ответить на тему   [ Сообщений: 8 ] 

Кто сейчас на конференции

Сейчас этот форум просматривают: Maxische и гости: 10


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  
Создано на основе phpBB® Forum Software © phpBB Group
Designed by ST Software for PTF.
Русская поддержка phpBB