Сообщения без ответов | Активные темы Текущее время: 13 дек 2019, 06:50



Ответить на тему  [ Сообщений: 3 ] 
Простая задачка про NAT и роутинг 
Автор Сообщение

Зарегистрирован: 08 апр 2013, 11:54
Сообщения: 14
Доброго дня.

Есть 3945 (c3900-universalk9_npe-mz.SPA.150-1.M4) с таким вот набором:

interface Vlan202
description Internet via FastEthernet0/0/1
ip address 1.2.3.109 255.255.255.248 secondary
ip address 1.2.3.108 255.255.255.248 secondary
ip address 1.2.3.107 255.255.255.248 secondary
ip address 1.2.3.106 255.255.255.248
ip flow ingress
ip flow egress
ip nat outside
ip virtual-reassembly

interface GigabitEthernet0/1
description LAN
ip address 10.11.4.43 255.255.255.0
ip flow ingress
ip flow egress
ip nat inside
ip virtual-reassembly

Ну и правило
ip nat inside source static tcp 10.11.4.100 25 1.2.3.109 25 extendable

При доступе извне - все работает штатно:

sh ip nat tr | i 4.100
....
tcp 1.2.3.109:25 10.11.4.100:25 80.69.186.123:62149 80.69.186.123:62149
....

А вот обратный траф (от хоста 10.11.4.100) - наружу выходит с первого ip-адреса интерфейса vlan202

sh ip nat tr | i 4.100
...
tcp 1.2.3.106:40944 10.11.4.100:40944 108.177.14.26:25 108.177.14.26:25
...

Со стороны хоста - с роутингом все просто:

root@mx7:/var/log# ip ro
default via 10.11.4.43 dev ens34 proto static

Ткните плз носом - в какую сторону копать?
Заранее спасибо.


15 ноя 2019, 13:06
Профиль

Зарегистрирован: 07 сен 2014, 02:54
Сообщения: 351
Откуда: Moscow
inoyat писал(а):
Ткните плз носом - в какую сторону копать?

1. Странно, что оно вообще куда-то NAT-ится.
Скорее всего конфиг приведен не весь.

ip nat inside source static tcp 10.11.4.100 25 1.2.3.109 25 extendable
tcp 1.2.3.106:40944 10.11.4.100:40944 108.177.14.26:25 108.177.14.26:25

2. Нафига вы накорячили столько secondary адресов?
NAT нормально прописывается и работает на любой адрес из диапазона внешнего интерфейса.

_________________
Knowledge is Power


15 ноя 2019, 15:16
Профиль

Зарегистрирован: 07 сен 2014, 02:54
Сообщения: 351
Откуда: Moscow
Сделайте статику IP-to-IP:

ip nat inside source static 10.11.4.100 1.2.3.109

_________________
Knowledge is Power


15 ноя 2019, 17:50
Профиль
Показать сообщения за:  Поле сортировки  
Ответить на тему   [ Сообщений: 3 ] 

Кто сейчас на конференции

Сейчас этот форум просматривают: Google Adsense [Bot] и гости: 20


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  
Создано на основе phpBB® Forum Software © phpBB Group
Designed by ST Software for PTF.
Русская поддержка phpBB