Сообщения без ответов | Активные темы Текущее время: 09 июл 2020, 00:36



Ответить на тему  [ Сообщений: 3 ] 
ISR 4331 port range forwarding 
Автор Сообщение

Зарегистрирован: 25 июн 2020, 12:31
Сообщения: 1
есть необходимость пробросить пул портов для конкретного хоста внутри локалки. nat- pat (overload) один белый ip.


192.168.4.3- хост
1.1.1.1 - внешний ip



description INTERNET
ip address 1.1.1.1 255.255.255.252
ip nat outside
negotiation auto



ip nat inside source list ACL_NAT interface GigabitEthernet0/0/0 overload
ip access-list standard ACL_NAT
permit 192.168.2.0 0.0.0.255
permit 192.168.3.0 0.0.0.255
permit 192.168.4.0 0.0.0.255


пробовал так:
p nat pool cPool 192.168.4.3 192.168.4.3 netmask 255.255.255.0 type rotary
ip access-list extended C_ACL
permit tcp any any range 1560 1591
permit tcp any host 1.1.1.1 range 1560 1591
ip nat inside destination list C_ACL pool cPool



и так :

ip nat inside source static 192.168.4.3 1.1.1.1 route-map MAP extendable
access-list 101 permit tcp host 192.168.4.3 range 1560 1591 any
route-map MAP permit 10
match ip address 101

открывает только начальный порт 1560...


26 июн 2020, 14:31
Профиль

Зарегистрирован: 12 фев 2015, 10:47
Сообщения: 58
Например так:
Код:
ip nat inside source static tcp 192.168.4.3 1560 1.1.1.1 1560  extendable
ip nat inside source static tcp 192.168.4.3 1561 1.1.1.1 1561  extendable
ip nat inside source static tcp 192.168.4.3 1562 1.1.1.1 1562  extendable
ip nat inside source static tcp 192.168.4.3 1563 1.1.1.1 1563  extendable
ip nat inside source static tcp 192.168.4.3 1564 1.1.1.1 1564  extendable
...


Либо так:
Код:
ip nat inside source static 192.168.4.3 1.1.1.1  extendable

ip access-list extended FROMINTERNET
permit tcp any host 1.1.1.1 range 1560 1591

Interface ...
description INTERNET
ip address 1.1.1.1 255.255.255.252
ip nat outside
negotiation auto
ip access-group FROMINTERNET in


P.S. Я надеюсь, что на интерфейсе, подключенном к интернету, уже есть ACL. И именно в него нужно добавить строчку permit tcp any host 1.1.1.1 range 1560 1591


26 июн 2020, 14:45
Профиль

Зарегистрирован: 01 янв 1970, 03:00
Сообщения: 844
сотрудники клаудфлейр опять забыли как конфигурится циска))))


26 июн 2020, 16:26
Профиль
Показать сообщения за:  Поле сортировки  
Ответить на тему   [ Сообщений: 3 ] 

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 23


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  
Создано на основе phpBB® Forum Software © phpBB Group
Designed by ST Software for PTF.
Русская поддержка phpBB