Сообщения без ответов | Активные темы Текущее время: 10 дек 2018, 00:22



Ответить на тему  [ Сообщений: 2 ] 
Подключение FEX к NEXUS 5672 
Автор Сообщение

Зарегистрирован: 27 фев 2012, 16:23
Сообщения: 82
Всем привет, коллеги.
У нас стоит задача подключения расширителей/экстендеров FEX к двум Nexus. Опыта пока не имеем.Планируем подключать по dual-home схеме. На данный момент Nexus объединены в VPC домен и работают в промышленном режиме, поэтому не хочется возможных осечек с этими работами.
В связи с этим вопросы:
1) есть ли какие-то подводные камни этого процесса, которые нужно учесть. Например, ребут Nexus) или еще что.
2) По рекомендуемым гайдам и примерам конфигурации планируем что-то подобное в конфиге Nexus для подключаемых FEX:

На Nexus1:
interface Ethernet1/1
description FEX-101-PORT-2
switchport mode fex-fabric
fex associate 101
channel-group 101

interface Ethernet1/2
description FEX-101-PORT-4
switchport mode fex-fabric
fex associate 101
channel-group 101

interface port-channel101
switchport mode fex-fabric
fex associate 101
vpc 101
description UPLINK FEX-01

interface Ethernet1/3
description FEX-102-PORT-1
switchport mode fex-fabric
fex associate 102
channel-group 102

interface Ethernet1/4
description FEX-102-PORT-3
switchport mode fex-fabric
fex associate 102
channel-group 102

interface port-channel102
switchport mode fex-fabric
fex associate 102
vpc 102
description UPLINK FEX-02

На Nexus2:
interface Ethernet1/1
description FEX-101-PORT-2
switchport mode fex-fabric
fex associate 101
channel-group 101

interface Ethernet1/2
description FEX-101-PORT-4
switchport mode fex-fabric
fex associate 101
channel-group 101

interface port-channel101
switchport mode fex-fabric
fex associate 101
vpc 101
description UPLINK FEX-01

interface Ethernet1/3
description FEX-102-PORT-2
switchport mode fex-fabric
fex associate 102
channel-group 102

interface Ethernet1/4
description FEX-102-PORT-4
switchport mode fex-fabric
fex associate 102
channel-group 102

interface port-channel102
switchport mode fex-fabric
fex associate 102
vpc 102
description UPLINK FEX-02

Вопрос: правильно ли я понимаю, что на каждый FEX нужно добавлять свой отдельный номер VPC?

Еще вопрос - как после подключения fex конфигурировать vlan на портах FEX.

Всем заранее спасибо!


07 авг 2017, 16:12
Профиль

Зарегистрирован: 12 дек 2014, 12:07
Сообщения: 122
Цитата:
Еще вопрос - как после подключения fex конфигурировать vlan на портах FEX.

Порты FEX-ов будут доступны после того, как нексус их [фексы] увидит.
Например, вот sh run на нашем нексус9к:

Код:
interface Ethernet1/49
  description PEER-LINK
  switchport mode trunk
  channel-group 100

interface Ethernet1/50

interface Ethernet1/51
  description PEER-LINK
  switchport mode trunk
  channel-group 100

interface Ethernet1/52

interface Ethernet1/53

interface Ethernet1/54

interface mgmt0
  vrf member management
  ip address 1.1.1.1/30
------ вот тут порты фексов--------------------
interface Ethernet101/1/1
  description SW-BC_1.1
  switchport access vlan 111
  spanning-tree bpdufilter enable
  channel-group 11 mode active

interface Ethernet101/1/2
  description SW-BC_1.1
  switchport access vlan 111
  spanning-tree bpdufilter enable
  channel-group 11 mode active


Вся настройка фекса в нашем случае:
Цитата:
feature-set fex
feature vpc
fex 101
pinning max-links 1
description "FEX0101"


interface port-channel101
description FEX_101
switchport mode fex-fabric
fex associate 101

SW_Nexus_9372PX_1# sh run int Eth1/48

!Command: show running-config interface Ethernet1/48
!Time: Tue Aug 29 11:00:48 2017

version 6.1(2)I3(3a)

interface Ethernet1/48
description FEX_101
switchport mode fex-fabric
fex associate 101
channel-group 101

SW_Nexus_9372PX_1# sh run int Eth1/47

!Command: show running-config interface Ethernet1/47
!Time: Tue Aug 29 11:00:52 2017

version 6.1(2)I3(3a)

interface Ethernet1/47
description FEX_101
switchport mode fex-fabric
fex associate 101
channel-group 101



Но у нас н9к и на момент инсталляции NX-OS не поддерживала dual-homed схему включения. Каждый фекс у нас подключен как плата расширения к своему нексусу.


29 авг 2017, 11:02
Профиль Отправить email
Показать сообщения за:  Поле сортировки  
Ответить на тему   [ Сообщений: 2 ] 

Кто сейчас на конференции

Сейчас этот форум просматривают: Baidu [Spider] и гости: 12


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  
Создано на основе phpBB® Forum Software © phpBB Group
Designed by ST Software for PTF.
Русская поддержка phpBB